caddy — security advisory
Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/rewrite/rewrite.go, Rewrite.Rewrite() can pass attacker-controlled replacement bytes through buildQueryString for a second placeholder expansion when a rewrite URI ends with a literal question mark, allowing injected environment or request-variable placeholders to disclose data and, when the file provider is registered, allowing injected file placeholders to disclose readable files. The issue is fixed in version 2.11.4.
- Products
- caddy
- Affected versions
- 2.11.2-1, 2.11.2-1~bpo13+1, 2.11.4-1, 2.6.2-12, 2.6.2-12+deb13u1, 2.6.2-13, 2.6.2-14, 2.6.2-5
- Fixed versions
- 2.11.4-1, 2.6.2-5+deb12u1
- CVEs
- CVE-2026-77281
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 09:33 UTC · Revision 1
Source evidence
Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/rewrite/rewrite.go, Rewrite.Rewrite() can pass attacker-controlled replacement bytes through buildQueryString for a second placeholder expansion when a rewrite URI ends with a literal question mark, allowing injected environment or request-variable placeholders to disclose data and, when the file provider is registered, allowing injected file placeholders to disclose readable files. The issue is fixed in version 2.11.4.
osv:DEBIAN-CVE-2026-77281
caddy
Fixed versions: 2.6.2-5+deb12u1
caddy
Fixed versions: Not specified
caddy
Fixed versions: 2.11.4-1
Complete source record
{
"id": "0b94001038bf73c82dd4b7612129f0353975836a32beef01bac535e212b04e04",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-77281",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-77281",
"summary": "Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/rewrite/rewrite.go, Rewrite.Rewrite() can pass attacker-controlled replacement bytes through buildQueryString for a second placeholder expansion when a rewrite URI ends with a literal question mark, allowing injected environment or request-variable placeholders to disclose data and, when the file provider is registered, allowing injected file placeholders to disclose readable files. The issue is fixed in version 2.11.4.",
"evidence": "osv:DEBIAN-CVE-2026-77281",
"products": [
{
"name": {
"value": "caddy",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.6.2-5+deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "2.6.2-5",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "caddy",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.11.2-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.11.2-1~bpo13+1",
"evidence": "/affected/1/versions"
},
{
"value": "2.11.4-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.6.2-12",
"evidence": "/affected/1/versions"
},
{
"value": "2.6.2-12+deb13u1",
"evidence": "/affected/1/versions"
},
{
"value": "2.6.2-13",
"evidence": "/affected/1/versions"
},
{
"value": "2.6.2-14",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "caddy",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.11.4-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "2.11.2-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.11.2-1~bpo13+1",
"evidence": "/affected/2/versions"
},
{
"value": "2.6.2-12",
"evidence": "/affected/2/versions"
},
{
"value": "2.6.2-13",
"evidence": "/affected/2/versions"
},
{
"value": "2.6.2-14",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2026-77281",
"aliases": [
"DEBIAN-CVE-2026-77281"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.2-5+deb12u1"
}
]
}
],
"package": {
"name": "caddy",
"purl": "pkg:deb/debian/caddy?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.6.2-5"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-77281.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "caddy",
"purl": "pkg:deb/debian/caddy?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"2.11.2-1",
"2.11.2-1~bpo13+1",
"2.11.4-1",
"2.6.2-12",
"2.6.2-12+deb13u1",
"2.6.2-13",
"2.6.2-14"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-77281.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.11.4-1"
}
]
}
],
"package": {
"name": "caddy",
"purl": "pkg:deb/debian/caddy?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"2.11.2-1",
"2.11.2-1~bpo13+1",
"2.6.2-12",
"2.6.2-13",
"2.6.2-14"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-77281.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-24T18:00:08.104954708Z",
"provider": "osv",
"upstream": [
"CVE-2026-77281"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-77281"
]
},
"related_cves": [
{
"value": "CVE-2026-77281",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 444076,
"published_at": "2026-09-17T21:17:37.89+00:00"
}