Medium
Security advisory
Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-3573
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 6 Nov 2026, 01:01 UTC · Revision 1
Source evidence
Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.
osv:CVE-2025-3573
Complete source record
{
"id": "baa6fe0ff106599cd33ed85ec73948b921bdde39e8de2b6e2e3402f3be3de55e",
"url": "https://osv.dev/vulnerability/CVE-2025-3573",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2025-3573",
"summary": "Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.",
"evidence": "osv:CVE-2025-3573",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-3573",
"aliases": [
"CVE-2025-3573",
"GHSA-rrj2-ph5q-jxw2"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jquery-validation/jquery-validation",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "6c5e8525f87c92261154877ad2379c645eeab590"
},
{
"fixed": "7a490d8f39bd988027568ddcf51755e1f4688902"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "1.20.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"fixed": "7a490d8f39bd988027568ddcf51755e1f4688902"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"1.11.1",
"1.11.0",
"1.10.0",
"1.9.0",
"1.8.1",
"1.8.0",
"1.8.0pre",
"1.7.0",
"1.6.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-3573.json"
}
}
],
"modified": "2026-10-28T02:30:45.737440404Z",
"provider": "osv",
"references": [
"https://security.snyk.io/vuln/SNYK-JS-JQUERYVALIDATION-5952285",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/3xxx/CVE-2025-3573.json",
"https://nvd.nist.gov/vuln/detail/CVE-2025-3573",
"https://github.com/jquery-validation/jquery-validation/commit/7a490d8f39bd988027568ddcf51755e1f4688902",
"https://github.com/jquery-validation/jquery-validation/pull/2462"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "snyk",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/3xxx/CVE-2025-3573.json"
}
},
"related_cves": [
{
"value": "CVE-2025-3573",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 513687,
"published_at": "2025-04-15T05:00:09.474+00:00"
}