Caddy: FastCGI header normalization bypass in `forward_auth copy_headers`
Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through php_fastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with _. This lets a client send an underscore alias that survives the forward_auth delete step but becomes the same PHP/FastCGI variable. Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. This vulnerability is fixed in 2.11.4.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-52845
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 16:39 UTC · Revision 1
Source evidence
Caddy: FastCGI header normalization bypass in `forward_auth copy_headers`
core-osv · Original sourcePublished 23 Jun 2026, 17:52 UTC
Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through php_fastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with _. This lets a client send an underscore alias that survives the forward_auth delete step but becomes the same PHP/FastCGI variable. Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. This vulnerability is fixed in 2.11.4.
osv:CVE-2026-52845
Complete source record
{
"id": "7349768c6be4d481131157f40a0d00d6b94f120ef881448b4bf86569e0976672",
"url": "https://osv.dev/vulnerability/CVE-2026-52845",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Caddy: FastCGI header normalization bypass in `forward_auth copy_headers`",
"summary": "Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through php_fastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with _. This lets a client send an underscore alias that survives the forward_auth delete step but becomes the same PHP/FastCGI variable. Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. This vulnerability is fixed in 2.11.4.",
"evidence": "osv:CVE-2026-52845",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-52845",
"aliases": [
"CVE-2026-52845",
"GHSA-f59h-q822-g45g",
"GO-2026-5346"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/caddyserver/caddy",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "e2eee6a7fce366321294c9c2a79f3146891dcbdf"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "2.11.4"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:caddyserver:caddy:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.11.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.11.3",
"v2.11.2",
"v2.11.1",
"v2.11.0",
"v2.11.0-beta.2",
"v2.11.0-beta.1",
"v2.10.2",
"v2.10.1",
"v2.10.0",
"v2.10.0-beta.4",
"v2.10.0-beta.3",
"v2.9.1",
"v2.10.0-beta.2",
"v2.10.0-beta.1",
"v2.9.0",
"v2.9.0-beta.3",
"v2.9.0-beta.2",
"v2.9.0-beta.1",
"v2.8.4",
"v2.8.3",
"v2.8.2",
"v2.8.1",
"v2.8.0",
"v2.8.0-rc.1",
"v2.8.0-beta.2",
"v2.8.0-beta.1",
"v2.7.5",
"v2.7.4",
"v2.7.3",
"v2.7.2",
"v2.7.1",
"v2.7.0",
"v2.7.0-beta.2",
"v2.7.0-beta.1",
"v2.6.4",
"v2.6.3",
"v2.6.2",
"v2.6.1",
"v2.6.0",
"v2.6.0-beta.5",
"v2.6.0-beta.4",
"v2.6.0-beta.3",
"v2.6.0-beta.2",
"v2.6.0-beta.1",
"v2.5.2",
"v2.5.1",
"v2.5.0",
"v2.5.0-rc.1",
"v2.5.0-beta.1",
"v2.4.6",
"v2.4.5",
"v2.4.4",
"v2.4.3",
"v2.4.2",
"v2.4.1",
"v2.4.0",
"v2.4.0-rc.1",
"v2.4.0-beta.2",
"v2.4.0-beta.1",
"v2.3.0-rc.2",
"v2.3.0",
"v2.3.0-rc.1",
"v2.3.0-beta.1",
"v2.2.3",
"v2.2.1",
"v2.2.0",
"v2.2.0-rc.3",
"v2.2.0-rc.2",
"v2.2.0-rc.1",
"v2.1.1",
"v2.1.0",
"v2.1.0-beta.2",
"v2.1.0-beta.1",
"v2.0.0",
"v2.0.0-rc.3",
"v2.0.0-rc.2",
"v2.0.0-rc.1",
"v2.0.0-beta.20",
"v2.0.0-beta.19",
"v2.0.0-beta.18",
"v2.0.0-beta.17",
"v2.0.0-beta.16",
"v2.0.0-beta.15",
"v2.0.0-beta.14",
"v2.0.0-beta.13",
"v2.0.0-beta12",
"v2.0.0-beta11",
"v2.0.0-beta10",
"v2.0.0-beta9",
"v2.0.0-beta8",
"v2.0.0-beta7",
"v2.0.0-beta6",
"v2.0.0-beta5",
"v2.0.0-beta4",
"v2.0.0-beta3",
"v2.0.0-beta2",
"v2.0.0-beta1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-52845.json"
}
}
],
"modified": "2026-10-28T02:30:37.230804115Z",
"provider": "osv",
"references": [
"https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-52845.json",
"https://access.redhat.com/security/cve/CVE-2026-52845",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/52xxx/CVE-2026-52845.json",
"https://github.com/caddyserver/caddy/security/advisories/GHSA-f59h-q822-g45g",
"https://nvd.nist.gov/vuln/detail/CVE-2026-52845",
"https://bugzilla.redhat.com/show_bug.cgi?id=2491907"
],
"provider_metadata": {
"cwe_ids": [
"CWE-287",
"CWE-290",
"CWE-444"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/52xxx/CVE-2026-52845.json"
}
},
"related_cves": [
{
"value": "CVE-2026-52845",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 504815,
"published_at": "2026-06-23T17:52:01.871+00:00"
}