Skip to content
Heist/ feed
Back to feed
HighFix available

Ghost 4.0.0 before 6.63.0 Restricted Content Bypass

Type: advisorySources: OSV

Ghost versions from 4.0.0 before 6.63.0 contain a content API vulnerability that allows unauthenticated visitors to access gated post content. Attackers can bypass content restrictions by directly querying the content API to retrieve restricted posts without authentication.

Products
ghost
Affected versions
Not specified
Fixed versions
6.63.0
CVEs
CVE-2026-103271
Confirmed fixed CVEs
Not specified
Updated in this feed
28 Oct 2026, 12:32 UTC · Revision 1

Source evidence

Ghost 4.0.0 before 6.63.0 Restricted Content Bypass

core-osv · Original source

Published 9 Oct 2026, 10:44 UTC

Ghost versions from 4.0.0 before 6.63.0 contain a content API vulnerability that allows unauthenticated visitors to access gated post content. Attackers can bypass content restrictions by directly querying the content API to retrieve restricted posts without authentication.

osv:BIT-ghost-2026-103271

ghost

Fixed versions: 6.63.0

Complete source record
{
  "id": "e3489e7646b023c0bddb1ab9d6266802cc89ff244ae0bd9e1d7e3d7808caa876",
  "url": "https://osv.dev/vulnerability/BIT-ghost-2026-103271",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Ghost 4.0.0 before 6.63.0 Restricted Content Bypass",
    "summary": "Ghost versions from 4.0.0 before 6.63.0 contain a content API vulnerability that allows unauthenticated visitors to access gated post content. Attackers can bypass content restrictions by directly querying the content API to retrieve restricted posts without authentication.",
    "evidence": "osv:BIT-ghost-2026-103271",
    "products": [
      {
        "name": {
          "value": "ghost",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "6.63.0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "BIT-ghost-2026-103271",
      "aliases": [
        "BIT-ghost-2026-103271",
        "CVE-2026-103271",
        "GHSA-rcx7-6m7p-xw5c"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "4.0.0"
                },
                {
                  "fixed": "6.63.0"
                }
              ]
            }
          ],
          "package": {
            "name": "ghost",
            "purl": "pkg:bitnami/ghost",
            "ecosystem": "Bitnami"
          },
          "severity": [
            {
              "type": "CVSS_V4",
              "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
            }
          ],
          "database_specific": {
            "source": "https://github.com/bitnami/vulndb/tree/main/data/ghost/BIT-ghost-2026-103271.json"
          }
        }
      ],
      "modified": "2026-10-09T12:10:49.219363771Z",
      "provider": "osv",
      "references": [
        "https://github.com/TryGhost/Ghost/security/advisories/GHSA-rcx7-6m7p-xw5c",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-103271",
        "https://www.vulncheck.com/advisories/ghost-4.0.0-before-6.63.0-restricted-content-bypass"
      ],
      "provider_metadata": {
        "cpes": [
          "cpe:2.3:a:ghost:ghost:*:*:*:*:*:node.js:*:*"
        ],
        "severity": "High"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-103271",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 120749,
  "published_at": "2026-10-09T10:44:49.293+00:00"
}