Medium
Security advisory
An issue was discovered in the Source Integration plugin before 1.5.9 and 2.x before 2.1.5 for MantisBT. A cross-site scripting (XSS) vulnerability in the Manage Repository and Changesets List pages allows execution of arbitrary code (if CSP settings permit it) via repo_manage_page.php or list.php.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-16362
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:04 UTC · Revision 1
Source evidence
An issue was discovered in the Source Integration plugin before 1.5.9 and 2.x before 2.1.5 for MantisBT. A cross-site scripting (XSS) vulnerability in the Manage Repository and Changesets List pages allows execution of arbitrary code (if CSP settings permit it) via repo_manage_page.php or list.php.
osv:CVE-2018-16362
Complete source record
{
"id": "89d402ab64d08002617c7f55db5dfc68bccafa5c239b3ec5e8717be2a8aa249d",
"url": "https://osv.dev/vulnerability/CVE-2018-16362",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-16362",
"summary": "An issue was discovered in the Source Integration plugin before 1.5.9 and 2.x before 2.1.5 for MantisBT. A cross-site scripting (XSS) vulnerability in the Manage Repository and Changesets List pages allows execution of arbitrary code (if CSP settings permit it) via repo_manage_page.php or list.php.",
"evidence": "osv:CVE-2018-16362",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2018-16362",
"aliases": [
"CVE-2018-16362"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/mantisbt-plugins/source-integration",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "b37c66556088cfafe1982e2bcb0019ef5e7008b7"
},
{
"introduced": "61a604800f1fd2303c13885750f26482e5bbf03b"
},
{
"fixed": "faac1b95f24bc329142b53d9a5f899c924113816"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:mantisbt:source_integration:*:*:*:*:*:mantisbt:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.5.9"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:mantisbt:source_integration:*:*:*:*:*:mantisbt:*:*",
"range": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.1.5"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "b37c66556088cfafe1982e2bcb0019ef5e7008b7"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v1.5.9"
},
{
"range": [
{
"fixed": "faac1b95f24bc329142b53d9a5f899c924113816"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v2.1.5"
}
]
}
}
],
"versions": [
"v1.5.8",
"v2.1.4",
"v1.5.7",
"v2.1.3",
"v2.1.2",
"v1.5.6",
"v1.5.5",
"v2.1.1",
"v1.5.4",
"v2.1.0",
"v1.5.3",
"v2.0.3",
"v1.5.2",
"v2.0.2",
"v1.5.1",
"v2.0.1",
"v2.0.0",
"v1.5.0",
"v1.4.1",
"v1.4.0",
"v1.3.2",
"v0.18",
"v0.17",
"v0.16.4",
"v0.16.3",
"v0.16.2",
"v0.16.1",
"v0.16",
"v0.15",
"v0.14",
"release-0.13.2",
"release-0.13.1",
"release-0.13.0",
"Source-0.12a",
"Source-0.12",
"Source-0.11",
"Source-0.10",
"Source-0.9c",
"Source-0.9b",
"Source-0.9a",
"Source-0.9"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-16362.json"
}
}
],
"modified": "2026-10-20T10:49:52.303323174Z",
"provider": "osv",
"references": [
"https://github.com/mantisbt-plugins/source-integration/issues/286",
"https://github.com/mantisbt-plugins/source-integration/releases/tag/v1.5.9",
"https://github.com/mantisbt-plugins/source-integration/releases/tag/v2.1.5"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2018-16362",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 380895,
"published_at": "2018-09-02T22:29:00.833+00:00"
}