BuddyBoss Platform Pro <= 2.7.01 - Authentication Bypass via Apple OAuth provider
The BuddyBoss Platform Pro plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.7.01. This is due to insufficient verification on the user being supplied during the Apple OAuth authenticate request through the plugin. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the email.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-1909
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 16:53 UTC · Revision 1
Source evidence
BuddyBoss Platform Pro <= 2.7.01 - Authentication Bypass via Apple OAuth provider
core-osv · Original sourcePublished 5 May 2025, 19:42 UTC
The BuddyBoss Platform Pro plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.7.01. This is due to insufficient verification on the user being supplied during the Apple OAuth authenticate request through the plugin. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the email.
osv:CVE-2025-1909
Complete source record
{
"id": "7f7f4ec478fe0d11ffa3ba0bd714f136df573a715177c0660afeb87362af9c27",
"url": "https://osv.dev/vulnerability/CVE-2025-1909",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "BuddyBoss Platform Pro <= 2.7.01 - Authentication Bypass via Apple OAuth provider",
"summary": "The BuddyBoss Platform Pro plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.7.01. This is due to insufficient verification on the user being supplied during the Apple OAuth authenticate request through the plugin. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the email.",
"evidence": "osv:CVE-2025-1909",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2025-1909",
"aliases": [
"CVE-2025-1909"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/buddyboss/buddyboss-platform",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "1274299201eafb528ba8a4b2e41a7522afc76c64"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:buddyboss:buddyboss_platform:*:*:*:*:pro:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.7.10"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.7.00",
"2.6.90",
"2.6.80",
"2.6.72",
"2.6.71",
"2.6.70",
"2.6.60",
"2.6.51",
"2.6.50",
"2.6.41",
"2.6.40",
"2.6.30",
"2.6.21",
"2.6.20",
"2.6.11",
"2.6.10",
"2.6.00",
"2.5.91",
"2.5.90",
"2.5.81",
"2.5.80",
"2.5.71",
"2.5.70",
"2.5.61",
"2.5.60",
"2.5.52",
"2.5.51",
"2.5.50",
"2.5.40",
"2.5.31",
"2.5.30",
"2.5.00",
"2.5.20",
"2.5.11",
"2.5.10",
"2.4.90",
"2.4.80",
"2.4.71",
"2.4.70",
"2.4.63",
"2.4.62",
"2.4.61",
"2.4.60",
"2.4.50",
"2.4.41",
"2.4.40",
"2.4.30",
"2.4.20",
"2.4.11",
"2.4.10",
"2.4.00",
"2.3.91",
"2.3.90",
"2.3.81",
"2.3.80",
"2.3.70",
"2.3.60",
"2.3.50",
"2.3.4",
"2.3.42",
"2.3.41",
"2.3.3",
"2.3.2",
"2.3.1.2",
"2.3.1.1",
"2.3.1",
"2.3.0",
"2.2.9.1",
"2.2.9",
"2.2.8",
"2.2.7.1",
"2.2.7",
"2.2.6.1",
"2.2.6",
"2.2.5",
"2.2.4",
"2.2.3",
"2.2.2",
"2.2.1",
"2.2",
"2.1.7.2",
"2.1.7.1",
"2.1.7",
"2.1.6.2",
"2.1.6.1",
"2.1.6",
"2.1.5",
"2.1.4.1",
"2.1.4",
"2.1.3",
"2.1.2",
"2.1.1.1",
"2.1.1",
"2.1.0",
"2.0.9",
"2.0.8",
"2.0.6",
"2.0.5",
"2.0.4.1",
"2.0.4",
"2.0.3.1",
"2.0.3",
"2.0.2",
"2.0.1.1",
"2.0.1",
"2.0.0",
"1.9.2",
"1.9.1.1",
"1.9.1",
"1.9.0.1",
"1.9.0",
"1.8.7",
"1.8.6",
"1.8.5",
"1.8.4",
"1.8.1",
"1.8.2",
"1.8.3",
"1.8.0",
"1.7.7.1",
"1.7.9",
"1.7.8",
"1.7.7",
"1.7.6",
"1.7.5",
"1.7.4",
"1.7.3",
"1.7.2.2",
"1.7.2.1",
"1.7.2",
"1.7.1",
"1.7.0.1",
"1.7.0",
"1.6.4",
"1.6.3",
"1.6.2",
"1.6.1",
"1.6.0",
"1.5.9",
"1.5.8.3",
"1.5.8.2",
"1.5.8.1",
"1.5.8",
"1.5.7.3",
"1.5.7.2",
"1.5.7.1",
"1.5.7",
"1.5.6",
"1.5.5.1",
"1.5.5",
"1.5.4",
"1.5.3",
"1.5.2",
"1.5.1.1",
"1.5.1",
"1.5.0",
"1.4.9",
"1.4.8",
"1.4.7",
"1.4.6",
"1.4.5",
"1.4.4",
"1.4.3",
"1.4.2",
"1.4.1",
"1.4.0.2",
"1.4.0.1",
"1.4.0",
"1.3.5",
"1.3.4",
"1.3.3",
"1.3.2",
"1.3.1",
"1.3.0",
"1.2.9.1",
"1.2.9",
"1.2.8",
"1.2.7",
"1.2.6",
"1.2.5",
"1.2.4",
"1.2.3",
"1.2.2.1",
"1.2.2",
"1.2.1.1",
"1.2.1",
"1.2.0",
"1.1.9",
"1.1.8.1",
"1.1.8",
"1.1.7",
"1.1.6",
"1.1.5",
"1.1.1",
"1.1.0",
"1.0.5",
"1.0.4",
"1.0.3",
"1.0.2",
"1.0.1",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-1909.json"
}
}
],
"modified": "2026-10-28T02:30:37.515877419Z",
"provider": "osv",
"references": [
"https://www.buddyboss.com/resources/buddyboss-platform-pro-releases/",
"https://www.buddyboss.com/resources/buddyboss-platform-pro-releases/2-7-10/",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/7cce9b8b-0589-4b09-b184-a66fc86fcb46?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/1xxx/CVE-2025-1909.json",
"https://nvd.nist.gov/vuln/detail/CVE-2025-1909"
],
"provider_metadata": {
"cwe_ids": [
"CWE-288"
],
"cna_assigner": "Wordfence",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "2.7.01"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/1xxx/CVE-2025-1909.json"
}
},
"related_cves": [
{
"value": "CVE-2025-1909",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 504932,
"published_at": "2025-05-05T19:42:25.763+00:00"
}