HighFix available
Ghost 2.5.0 before 6.34.0 Untrusted Script Execution via oEmbed
Type: advisorySources: OSV
Ghost versions from 2.5.0 before 6.34.0 contain an untrusted script execution vulnerability in the oEmbed preview feature that fails to sandbox externally hosted scripts. Attackers can craft malicious oEmbed content to execute scripts in the context of a staff user's admin session, potentially compromising administrative access.
- Products
- ghost
- Affected versions
- Not specified
- Fixed versions
- 6.34.0
- CVEs
- CVE-2026-103277
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 12:32 UTC · Revision 1
Source evidence
Ghost 2.5.0 before 6.34.0 Untrusted Script Execution via oEmbed
core-osv · Original sourcePublished 9 Oct 2026, 10:44 UTC
Ghost versions from 2.5.0 before 6.34.0 contain an untrusted script execution vulnerability in the oEmbed preview feature that fails to sandbox externally hosted scripts. Attackers can craft malicious oEmbed content to execute scripts in the context of a staff user's admin session, potentially compromising administrative access.
osv:BIT-ghost-2026-103277
ghost
Fixed versions: 6.34.0
Complete source record
{
"id": "b364753649cbbcd35ed9ce8645a30981d172c032990ac28afe5538f05928f6cd",
"url": "https://osv.dev/vulnerability/BIT-ghost-2026-103277",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Ghost 2.5.0 before 6.34.0 Untrusted Script Execution via oEmbed",
"summary": "Ghost versions from 2.5.0 before 6.34.0 contain an untrusted script execution vulnerability in the oEmbed preview feature that fails to sandbox externally hosted scripts. Attackers can craft malicious oEmbed content to execute scripts in the context of a staff user's admin session, potentially compromising administrative access.",
"evidence": "osv:BIT-ghost-2026-103277",
"products": [
{
"name": {
"value": "ghost",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.34.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "BIT-ghost-2026-103277",
"aliases": [
"BIT-ghost-2026-103277",
"CVE-2026-103277",
"GHSA-8vhf-xxpj-4qrg"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "2.5.0"
},
{
"fixed": "6.34.0"
}
]
}
],
"package": {
"name": "ghost",
"purl": "pkg:bitnami/ghost",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/ghost/BIT-ghost-2026-103277.json"
}
}
],
"modified": "2026-10-09T12:10:49.409879276Z",
"provider": "osv",
"references": [
"https://github.com/TryGhost/Ghost/security/advisories/GHSA-8vhf-xxpj-4qrg",
"https://nvd.nist.gov/vuln/detail/CVE-2026-103277",
"https://www.vulncheck.com/advisories/ghost-2.5.0-before-6.34.0-untrusted-script-execution-via-oembed"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:ghost:ghost:*:*:*:*:*:node.js:*:*"
],
"severity": "High"
}
},
"related_cves": [
{
"value": "CVE-2026-103277",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 120748,
"published_at": "2026-10-09T10:44:55.655+00:00"
}