Visualizer: Tables and Charts Manager for WordPress <= 3.7.9 - Authenticated (Contributor+) PHAR Deserialization
The Visualizer: Tables and Charts Manager for WordPress plugin for WordPress is vulnerable to deserialization of untrusted input via the 'remote_data' parameter in versions up to, and including 3.7.9. This makes it possible for authenticated attackers with contributor privileges and above to call files using a PHAR wrapper that will deserialize the data and call arbitrary PHP Objects that can be used to perform a variety of malicious actions granted a POP chain is also present. It also requires that the attacker is successful in uploading a file with the serialized payload.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-2444
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 18:08 UTC · Revision 1
Source evidence
Visualizer: Tables and Charts Manager for WordPress <= 3.7.9 - Authenticated (Contributor+) PHAR Deserialization
core-osv · Original sourcePublished 18 Jul 2022, 16:13 UTC
The Visualizer: Tables and Charts Manager for WordPress plugin for WordPress is vulnerable to deserialization of untrusted input via the 'remote_data' parameter in versions up to, and including 3.7.9. This makes it possible for authenticated attackers with contributor privileges and above to call files using a PHAR wrapper that will deserialize the data and call arbitrary PHP Objects that can be used to perform a variety of malicious actions granted a POP chain is also present. It also requires that the attacker is successful in uploading a file with the serialized payload.
osv:CVE-2022-2444
Complete source record
{
"id": "5952d95660cbe8e53fbbf58c3e0822f95bc5b42d919c7cc3c545881024822dfb",
"url": "https://osv.dev/vulnerability/CVE-2022-2444",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Visualizer: Tables and Charts Manager for WordPress <= 3.7.9 - Authenticated (Contributor+) PHAR Deserialization",
"summary": "The Visualizer: Tables and Charts Manager for WordPress plugin for WordPress is vulnerable to deserialization of untrusted input via the 'remote_data' parameter in versions up to, and including 3.7.9. This makes it possible for authenticated attackers with contributor privileges and above to call files using a PHAR wrapper that will deserialize the data and call arbitrary PHP Objects that can be used to perform a variety of malicious actions granted a POP chain is also present. It also requires that the attacker is successful in uploading a file with the serialized payload.",
"evidence": "osv:CVE-2022-2444",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2022-2444",
"aliases": [
"CVE-2022-2444"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/codeinwp/visualizer",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "6fa01e7496947364c01ac0a5749e0a674930d9c6"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"last_affected": "3.7.9"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"cpe": "cpe:2.3:a:themeisle:visualizer:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.7.10"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v3.7.9",
"v3.7.8",
"v3.7.7",
"v3.7.6",
"v3.7.5",
"v3.7.4",
"v3.7.3",
"v3.7.2",
"v3.7.1",
"v3.7.0",
"v3.6.1",
"v3.6.0",
"v3.5.1",
"v3.5.0",
"v3.4.11",
"v3.4.10",
"v3.4.9",
"v3.4.8",
"v3.4.7",
"v3.4.6",
"v3.4.5",
"v3.4.4",
"v3.4.3",
"v3.4.2",
"v3.4.1",
"v3.4.0",
"v3.3.4",
"v3.3.2",
"v3.3.3",
"v3.3.1",
"v3.3.0",
"v3.2.1",
"v3.2.0",
"v3.1.3",
"v3.1.2",
"v3.1.1",
"v3.1.0",
"v3.0.12",
"v3.0.11",
"v3.0.9",
"v3.0.10",
"v3.0.8",
"v3.0.7",
"v3.0.6",
"v3.0.5",
"v3.0.4",
"v3.0.2",
"v3.0.3",
"v3.0.1",
"v3.0.0",
"v2.2.0",
"v2.1.9",
"v2.1.8",
"v2.1.7",
"v2.1.6",
"v2.1.5",
"v2.1.4",
"v2.1.3",
"v2.1.1",
"v2.1.0",
"v2.0.4",
"v2.0.3",
"untagged-43bc5985e1f581467953",
"untagged-fa4a1433cf1a8da886ac",
"v2.0.2",
"v2.0.1",
"v2.0.0",
"untagged-a389242c40bc7749f453",
"v1.7.6",
"v1.7.5",
"v1.7.2",
"v1.7.1",
"v1.7.0",
"v1.6.6",
"v1.6.5",
"v1.6.0",
"v1.5.6",
"v1.5.5",
"v1.5.4",
"v1.5.3",
"v1.5.2",
"v1.5"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-2444.json"
}
}
],
"modified": "2026-10-28T02:30:22.042194668Z",
"provider": "osv",
"references": [
"https://github.com/Codeinwp/visualizer/blob/master/classes/Visualizer/Module/Chart.php#L1115",
"https://github.com/Codeinwp/visualizer/blob/master/classes/Visualizer/Source/Csv.php",
"https://github.com/Codeinwp/visualizer/compare/v3.7.9...v3.7.10",
"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2752058%40visualizer&new=2752058%40visualizer&sfp_email=&sfph_mail=",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/d9606d92-8061-4dfc-a6e2-509b54613277?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2444.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-2444",
"https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2444"
],
"provider_metadata": {
"cwe_ids": [
"CWE-502"
],
"cna_assigner": "Wordfence",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2444.json"
}
},
"related_cves": [
{
"value": "CVE-2022-2444",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 488106,
"published_at": "2022-07-18T16:13:34+00:00"
}