Skip to content
Heist/ feed
Back to feed
Medium

ModSecurity's Insufficient Return Value Handling can Lead to XSS and Source Code Disclosure

Type: advisorySources: OSV

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. In versions 2.9.11 and below, an attacker can override the HTTP response’s Content-Type, which could lead to several issues depending on the HTTP scenario. For example, we have demonstrated the potential for XSS and arbitrary script source code disclosure in the latest version of mod_security2. This issue is fixed in version 2.9.12.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-54571
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 21:29 UTC · Revision 1

Source evidence

ModSecurity's Insufficient Return Value Handling can Lead to XSS and Source Code Disclosure

core-osv · Original source

Published 5 Aug 2025, 23:39 UTC

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. In versions 2.9.11 and below, an attacker can override the HTTP response’s Content-Type, which could lead to several issues depending on the HTTP scenario. For example, we have demonstrated the potential for XSS and arbitrary script source code disclosure in the latest version of mod_security2. This issue is fixed in version 2.9.12.

osv:CVE-2025-54571
Complete source record
{
  "id": "6eeb7643bd00cbd718ee7a36b2085d7885c6de291db1bf9a62815a327d4d8b03",
  "url": "https://osv.dev/vulnerability/CVE-2025-54571",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "ModSecurity's Insufficient Return Value Handling can Lead to XSS and Source Code Disclosure",
    "summary": "ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. In versions 2.9.11 and below, an attacker can override the HTTP response’s Content-Type, which could lead to several issues depending on the HTTP scenario. For example, we have demonstrated the potential for XSS and arbitrary script source code disclosure in the latest version of mod_security2. This issue is fixed in version 2.9.12.",
    "evidence": "osv:CVE-2025-54571",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2025-54571",
      "aliases": [
        "BIT-modsecurity-2025-54571",
        "BIT-modsecurity2-2025-54571",
        "CVE-2025-54571",
        "GHSA-cg44-9m43-3f9v"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/owasp-modsecurity/modsecurity",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "18cae5003a7160792a2e96000a9d6bd07cdf7ee2"
                },
                {
                  "fixed": "6d7e8eb18f2d7d368fb8e29516fcdeaeb8d349b8"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:owasp:modsecurity:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "2.0.0"
                      },
                      {
                        "fixed": "2.9.12"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "6d7e8eb18f2d7d368fb8e29516fcdeaeb8d349b8"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.9.11",
            "v2.9.10",
            "v2.9.9",
            "v2.9.7",
            "v2.9.6",
            "v2.9.5",
            "v2.9.4",
            "v2.9.3",
            "v2.9.2",
            "v2.9.1",
            "v2.9.1-rc1",
            "v2.9.0",
            "v2.9.0-rc2",
            "v2.9.0-rc1",
            "v2.7.4"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-54571.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:39.652415856Z",
      "provider": "osv",
      "references": [
        "https://lists.debian.org/debian-lts-announce/2025/09/msg00008.html",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/54xxx/CVE-2025-54571.json",
        "https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-cg44-9m43-3f9v",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-54571",
        "https://github.com/owasp-modsecurity/ModSecurity/issues/2514",
        "https://github.com/owasp-modsecurity/ModSecurity/commit/6d7e8eb18f2d7d368fb8e29516fcdeaeb8d349b8"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-252"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/54xxx/CVE-2025-54571.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-54571",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 507268,
  "published_at": "2025-08-05T23:39:40.712+00:00"
}