node-js-yaml — security advisory
js-yaml is a JavaScript YAML parser and dumper. In js-yaml before 4.1.1 and 3.14.2, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution (`__proto__`). All users who parse untrusted yaml documents may be impacted. The problem is patched in js-yaml 4.1.1 and 3.14.2. Users can protect against this kind of attack on the server by using `node --disable-proto=delete` or `deno` (in Deno, pollution protection is on by default).
- Products
- node-js-yaml
- Affected versions
- 4.1.0+dfsg+~4.0.5-7, 4.1.1+dfsg+~4.0.9-1, 4.2.0+~4.0.9-1, 4.2.0+~4.0.9-2, 4.3.2+~4.0.9-1
- Fixed versions
- 4.1.1+dfsg+~4.0.9-1
- CVEs
- CVE-2025-64718
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 09:03 UTC · Revision 1
Source evidence
js-yaml is a JavaScript YAML parser and dumper. In js-yaml before 4.1.1 and 3.14.2, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution (`__proto__`). All users who parse untrusted yaml documents may be impacted. The problem is patched in js-yaml 4.1.1 and 3.14.2. Users can protect against this kind of attack on the server by using `node --disable-proto=delete` or `deno` (in Deno, pollution protection is on by default).
osv:DEBIAN-CVE-2025-64718
node-js-yaml
Fixed versions: Not specified
node-js-yaml
Fixed versions: Not specified
node-js-yaml
Fixed versions: 4.1.1+dfsg+~4.0.9-1
Complete source record
{
"id": "57ac9867f7c5f5beed85e8945f0e813c21b9ff8d4be586e6cf59ca2f1bd4af3c",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-64718",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2025-64718",
"summary": "js-yaml is a JavaScript YAML parser and dumper. In js-yaml before 4.1.1 and 3.14.2, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution (`__proto__`). All users who parse untrusted yaml documents may be impacted. The problem is patched in js-yaml 4.1.1 and 3.14.2. Users can protect against this kind of attack on the server by using `node --disable-proto=delete` or `deno` (in Deno, pollution protection is on by default).",
"evidence": "osv:DEBIAN-CVE-2025-64718",
"products": [
{
"name": {
"value": "node-js-yaml",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.1.0+dfsg+~4.0.5-7",
"evidence": "/affected/0/versions"
},
{
"value": "4.1.1+dfsg+~4.0.9-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.2.0+~4.0.9-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.2.0+~4.0.9-2",
"evidence": "/affected/0/versions"
},
{
"value": "4.3.2+~4.0.9-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "node-js-yaml",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.1.0+dfsg+~4.0.5-7",
"evidence": "/affected/1/versions"
},
{
"value": "4.1.1+dfsg+~4.0.9-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.2.0+~4.0.9-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.2.0+~4.0.9-2",
"evidence": "/affected/1/versions"
},
{
"value": "4.3.2+~4.0.9-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "node-js-yaml",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.1.1+dfsg+~4.0.9-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "4.1.0+dfsg+~4.0.5-7",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2025-64718",
"aliases": [
"DEBIAN-CVE-2025-64718"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-js-yaml",
"purl": "pkg:deb/debian/node-js-yaml?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"4.1.0+dfsg+~4.0.5-7",
"4.1.1+dfsg+~4.0.9-1",
"4.2.0+~4.0.9-1",
"4.2.0+~4.0.9-2",
"4.3.2+~4.0.9-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-64718.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-js-yaml",
"purl": "pkg:deb/debian/node-js-yaml?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"4.1.0+dfsg+~4.0.5-7",
"4.1.1+dfsg+~4.0.9-1",
"4.2.0+~4.0.9-1",
"4.2.0+~4.0.9-2",
"4.3.2+~4.0.9-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-64718.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.1.1+dfsg+~4.0.9-1"
}
]
}
],
"package": {
"name": "node-js-yaml",
"purl": "pkg:deb/debian/node-js-yaml?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"4.1.0+dfsg+~4.0.5-7"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-64718.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-08T10:00:26.990344755Z",
"provider": "osv",
"upstream": [
"CVE-2025-64718"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2025-64718"
]
},
"related_cves": [
{
"value": "CVE-2025-64718",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 98931,
"published_at": "2025-11-13T16:15:57.153+00:00"
}