Skip to content
Heist/ feed
Back to feed
UnratedFix available

Drupal core - Moderately critical - Cross-site scripting - SA-CORE-2026-012

Type: patchSources: Drupal security

A cross-site scripting flaw in Layout Builder block labels is addressed by updates to supported Drupal core releases.

Products
Drupal core
Affected versions
<10.6.13 || >=11.3.0 <11.3.14 || >=11.4.0 <11.4.4 || 11.0.* || 11.1.* || 11.2.*
Fixed versions
10.6.13, 11.3.14, 11.4.4
CVEs
CVE-2026-55805
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 12:08 UTC · Revision 1

Source evidence

Drupal core - Moderately critical - Cross-site scripting - SA-CORE-2026-012

official-drupal-security · Original source

Published 15 Jul 2026, 19:52 UTC

A cross-site scripting flaw in Layout Builder block labels is addressed by updates to supported Drupal core releases.

The Layout Builder module doesn't sufficiently sanitize block labels in certain scenarios, which can lead to a cross-site scripting (XSS) vulnerability.

Drupal core

Fixed versions: 11.4.4, 11.3.14, 10.6.13

Prerequisites: both the attacker and the targeted user need to be using the Layout Builder editing interface

Complete source record
{
  "id": "711bd2da7f51c30f7d5d9e97ccb0235155c2bbe0eaf83b7a182a438237e5c516",
  "url": "https://www.drupal.org/sa-core-2026-012",
  "method": "llm",
  "payload": {
    "kind": "patch",
    "title": "Drupal core - Moderately critical - Cross-site scripting - SA-CORE-2026-012",
    "summary": "A cross-site scripting flaw in Layout Builder block labels is addressed by updates to supported Drupal core releases.",
    "evidence": "The Layout Builder module doesn't sufficiently sanitize block labels in certain scenarios, which can lead to a cross-site scripting (XSS) vulnerability.",
    "products": [
      {
        "name": {
          "value": "Drupal core",
          "evidence": "Project: Drupal core"
        },
        "prerequisites": [
          {
            "value": "both the attacker and the targeted user need to be using the Layout Builder editing interface",
            "evidence": "This is mitigated by the fact that both the attacker and the targeted user need to be using the Layout Builder editing interface."
          }
        ],
        "fixed_versions": [
          {
            "value": "11.4.4",
            "evidence": "If you use Drupal 11.4.x, update to Drupal 11.4.4."
          },
          {
            "value": "11.3.14",
            "evidence": "If you use Drupal 11.3.x, update to Drupal 11.3.14."
          },
          {
            "value": "10.6.13",
            "evidence": "If you use Drupal 10.6.x, update to Drupal 10.6.13."
          }
        ],
        "affected_versions": [
          {
            "value": "<10.6.13 || >=11.3.0 <11.3.14 || >=11.4.0 <11.4.4 || 11.0.* || 11.1.* || 11.2.*",
            "evidence": "Affected versions: <10.6.13 || >=11.3.0 <11.3.14 || >=11.4.0 <11.4.4 || 11.0.* || 11.1.* || 11.2.*"
          }
        ]
      }
    ],
    "severity": "unknown",
    "fixed_cves": [],
    "related_cves": [
      {
        "value": "CVE-2026-55805",
        "evidence": "CVE IDs: CVE-2026-55805"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "official-drupal-security",
  "document_id": 23458,
  "published_at": "2026-07-15T19:52:26+00:00"
}