Roots soil Plugin CleanUpModule.php language_attributes cross site scripting
A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.0.x. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.0 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-4524
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 02:11 UTC · Revision 1
Source evidence
Roots soil Plugin CleanUpModule.php language_attributes cross site scripting
core-osv · Original sourcePublished 15 Dec 2022, 00:00 UTC
A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.0.x. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.0 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.
osv:CVE-2022-4524
Complete source record
{
"id": "25f70b6489048b3c8be415bf0fbf5978729b2973e529b66036f7c8529b1c8796",
"url": "https://osv.dev/vulnerability/CVE-2022-4524",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Roots soil Plugin CleanUpModule.php language_attributes cross site scripting",
"summary": "A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.0.x. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.0 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.",
"evidence": "osv:CVE-2022-4524",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2022-4524",
"aliases": [
"CVE-2022-4524",
"GHSA-jw6x-4h8h-569x"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/roots/soil",
"type": "GIT",
"events": [
{
"introduced": "98582d6a7c49b42e90336c508bfb26aa04ac8973"
},
{
"fixed": "0c9151e00ab047da253e5cdbfccb204dd423269d"
},
{
"fixed": "99499faf19a272f6aae3dd145b5a90d8f9a49d3e"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "4.0"
},
{
"last_affected": "4.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"fixed": "0c9151e00ab047da253e5cdbfccb204dd423269d"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "99499faf19a272f6aae3dd145b5a90d8f9a49d3e"
}
],
"source": "REFERENCES_TAG",
"original_tag": "4.1.0"
}
]
}
}
],
"versions": [
"4.0",
"4.0.5",
"4.0.4",
"4.0.3",
"4.0.2",
"4.0.1",
"4.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-4524.json"
}
}
],
"modified": "2026-10-28T02:30:41.884263147Z",
"provider": "osv",
"references": [
"https://github.com/roots/soil/releases/tag/4.1.0",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4524.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-4524",
"https://vuldb.com/?id.215904",
"https://github.com/roots/soil/commit/0c9151e00ab047da253e5cdbfccb204dd423269d",
"https://github.com/roots/soil/pull/285"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "VulDB",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4524.json"
}
},
"related_cves": [
{
"value": "CVE-2022-4524",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 509408,
"published_at": "2022-12-15T00:00:00+00:00"
}