Apache APISIX: cas-auth login CSRF / session injection issue
Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-49871
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 01:48 UTC · Revision 1
Source evidence
Apache APISIX: cas-auth login CSRF / session injection issue
core-osv · Original sourcePublished 19 Jun 2026, 13:18 UTC
Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
osv:CVE-2026-49871
Complete source record
{
"id": "e2e1ffe4fec4ea9b8b31e0848c29e907c091002cc53575dcde14d19b85103142",
"url": "https://osv.dev/vulnerability/CVE-2026-49871",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache APISIX: cas-auth login CSRF / session injection issue",
"summary": "Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.",
"evidence": "osv:CVE-2026-49871",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2026-49871",
"aliases": [
"BIT-apisix-2026-49871",
"CVE-2026-49871"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/apisix",
"type": "GIT",
"events": [
{
"introduced": "24d1ec762e4bee402cc98b5ca57a08531f3c0b51"
},
{
"fixed": "9ef2ecab67f652d38365049613610ef649bb4ad0"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.17.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-49871.json"
}
}
],
"modified": "2026-10-28T02:30:48.678674930Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/49xxx/CVE-2026-49871.json",
"https://lists.apache.org/thread/1ozsnss0lof4gpwq763d66oxwxt3sycp",
"https://nvd.nist.gov/vuln/detail/CVE-2026-49871"
],
"provider_metadata": {
"cwe_ids": [
"CWE-352"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "3.0.0"
},
{
"last_affected": "3.16.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/49xxx/CVE-2026-49871.json"
}
},
"related_cves": [
{
"value": "CVE-2026-49871",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 517106,
"published_at": "2026-06-19T13:18:36.767+00:00"
}