celery — security advisory
This affects the package celery before 5.2.2. It by default trusts the messages and metadata stored in backends (result stores). When reading task metadata from the backend, the data is deserialized. Given that an attacker can gain access to, or somehow manipulate the metadata within a celery backend, they could trigger a stored command injection vulnerability and potentially gain further access to the system.
- Products
- celery
- Affected versions
- Not specified
- Fixed versions
- 5.2.3-1
- CVEs
- CVE-2021-23727
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:20 UTC · Revision 1
Source evidence
This affects the package celery before 5.2.2. It by default trusts the messages and metadata stored in backends (result stores). When reading task metadata from the backend, the data is deserialized. Given that an attacker can gain access to, or somehow manipulate the metadata within a celery backend, they could trigger a stored command injection vulnerability and potentially gain further access to the system.
osv:DEBIAN-CVE-2021-23727
celery
Fixed versions: 5.2.3-1
celery
Fixed versions: 5.2.3-1
celery
Fixed versions: 5.2.3-1
Complete source record
{
"id": "48df57be85c8240cc2c70f2c93b5d0ffb2b1cb906ea8648318c893bb06a8fa7c",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-23727",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-23727",
"summary": "This affects the package celery before 5.2.2. It by default trusts the messages and metadata stored in backends (result stores). When reading task metadata from the backend, the data is deserialized. Given that an attacker can gain access to, or somehow manipulate the metadata within a celery backend, they could trigger a stored command injection vulnerability and potentially gain further access to the system.",
"evidence": "osv:DEBIAN-CVE-2021-23727",
"products": [
{
"name": {
"value": "celery",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.2.3-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "celery",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.2.3-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "celery",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.2.3-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2021-23727",
"aliases": [
"DEBIAN-CVE-2021-23727"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.2.3-1"
}
]
}
],
"package": {
"name": "celery",
"purl": "pkg:deb/debian/celery?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23727.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.2.3-1"
}
]
}
],
"package": {
"name": "celery",
"purl": "pkg:deb/debian/celery?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23727.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.2.3-1"
}
]
}
],
"package": {
"name": "celery",
"purl": "pkg:deb/debian/celery?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23727.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:11.884025702Z",
"provider": "osv",
"upstream": [
"CVE-2021-23727"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-23727"
]
},
"related_cves": [
{
"value": "CVE-2021-23727",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 420775,
"published_at": "2021-12-29T17:15:07.413+00:00"
}