Skip to content
Heist/ feed
Back to feed
Critical

Security advisory

Type: advisorySources: OSVCVE: CVE-2020-15086

In TYPO3 installations with the "mediace" extension from version 7.6.2 and before version 7.6.5, it has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. The allows to inject arbitrary data having a valid cryptographic message authentication code and can lead to remote code execution. To successfully exploit this vulnerability, an attacker must have access to at least one `Extbase` plugin or module action in a TYPO3 installation. This is fixed in version 7.6.5 of the "mediace" extension for TYPO3.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2020-15086
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 10:52 UTC · Revision 1

Source evidence

CVE-2020-15086

core-osv · Original source

Published 29 Jul 2020, 17:15 UTC

In TYPO3 installations with the "mediace" extension from version 7.6.2 and before version 7.6.5, it has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. The allows to inject arbitrary data having a valid cryptographic message authentication code and can lead to remote code execution. To successfully exploit this vulnerability, an attacker must have access to at least one `Extbase` plugin or module action in a TYPO3 installation. This is fixed in version 7.6.5 of the "mediace" extension for TYPO3.

osv:CVE-2020-15086
Complete source record
{
  "id": "97d8fa1fec26315a48799d10207c10c41dd763668c806aabbd6cc432985fa96a",
  "url": "https://osv.dev/vulnerability/CVE-2020-15086",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2020-15086",
    "summary": "In TYPO3 installations with the \"mediace\" extension from version 7.6.2 and before version 7.6.5, it has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. The allows to inject arbitrary data having a valid cryptographic message authentication code and can lead to remote code execution. To successfully exploit this vulnerability, an attacker must have access to at least one `Extbase` plugin or module action in a TYPO3 installation. This is fixed in version 7.6.5 of the \"mediace\" extension for TYPO3.",
    "evidence": "osv:CVE-2020-15086",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2020-15086",
      "aliases": [
        "CVE-2020-15086",
        "GHSA-4h44-w6fm-548g"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/friendsoftypo3/mediace",
              "type": "GIT",
              "events": [
                {
                  "introduced": "f95e9e46083a980a70e28d566002f10294ec117b"
                },
                {
                  "fixed": "cd705578691852a5a942ce8b676031985964182d"
                },
                {
                  "fixed": "fa29ffd3e8b275782a8600d2406e1b1e5e16ae75"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:typo3:mediace:*:*:*:*:*:typo3:*:*",
                    "range": [
                      {
                        "introduced": "7.6.2"
                      },
                      {
                        "fixed": "7.6.5"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "fa29ffd3e8b275782a8600d2406e1b1e5e16ae75"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "7.6.4",
            "7.6.3",
            "7.6.2"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-15086.json"
          }
        }
      ],
      "modified": "2026-10-20T10:51:52.073603359Z",
      "provider": "osv",
      "references": [
        "https://github.com/FriendsOfTYPO3/mediace/commit/fa29ffd3e8b275782a8600d2406e1b1e5e16ae75",
        "https://github.com/FriendsOfTYPO3/mediace/pull/31",
        "https://github.com/FriendsOfTYPO3/mediace/security/advisories/GHSA-4h44-w6fm-548g"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2020-15086",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 383044,
  "published_at": "2020-07-29T17:15:13.28+00:00"
}