Skip to content
Heist/ feed
Back to feed
High

OctoPrint-SpoolManager Plugin APIs do not enforce authentication

Type: advisorySources: OSV

OctoPrint-SpoolManager is a plugin for managing spools and all their usage metadata. In versions 1.8.0a2 and older of the testing branch and versions 1.7.7 and older of the stable branch, the APIs of the OctoPrint-SpoolManager plugin do not correctly enforce authentication or authorization checks. This issue has been patched in versions 1.8.0a3 of the testing branch and 1.7.8 of the stable branch. The impact of this vulnerability is greatly reduced when using OctoPrint version 1.11.2 and newer.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-62169
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 22:11 UTC · Revision 1

Source evidence

OctoPrint-SpoolManager Plugin APIs do not enforce authentication

core-osv · Original source

Published 23 Oct 2025, 16:09 UTC

OctoPrint-SpoolManager is a plugin for managing spools and all their usage metadata. In versions 1.8.0a2 and older of the testing branch and versions 1.7.7 and older of the stable branch, the APIs of the OctoPrint-SpoolManager plugin do not correctly enforce authentication or authorization checks. This issue has been patched in versions 1.8.0a3 of the testing branch and 1.7.8 of the stable branch. The impact of this vulnerability is greatly reduced when using OctoPrint version 1.11.2 and newer.

osv:CVE-2025-62169
Complete source record
{
  "id": "5b74c9619dc19ac959bfa72cddf1048f20554854364f0dcb6f7e9a581c4cc6f2",
  "url": "https://osv.dev/vulnerability/CVE-2025-62169",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "OctoPrint-SpoolManager Plugin APIs do not enforce authentication",
    "summary": "OctoPrint-SpoolManager is a plugin for managing spools and all their usage metadata. In versions 1.8.0a2 and older of the testing branch and versions 1.7.7 and older of the stable branch, the APIs of the OctoPrint-SpoolManager plugin do not correctly enforce authentication or authorization checks. This issue has been patched in versions 1.8.0a3 of the testing branch and 1.7.8 of the stable branch. The impact of this vulnerability is greatly reduced when using OctoPrint version 1.11.2 and newer.",
    "evidence": "osv:CVE-2025-62169",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2025-62169",
      "aliases": [
        "CVE-2025-62169",
        "GHSA-2rrc-f24f-94f6"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wildrikku/octoprint-spoolmanager",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "267c0a331223aa10199dfc8199daec351aa3d65c"
                },
                {
                  "fixed": "26af7f38a9ce41227af5aa29320fd2ec94333e34"
                },
                {
                  "fixed": "b725e113316e177ce81238a2dbbbdb63d92c40b0"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.8.0a3"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.7.8"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "b725e113316e177ce81238a2dbbbdb63d92c40b0"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "26af7f38a9ce41227af5aa29320fd2ec94333e34"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "1.7.8"
                  },
                  {
                    "range": [
                      {
                        "fixed": "267c0a331223aa10199dfc8199daec351aa3d65c"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "1.8.0a3"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.8.0a2",
            "1.7.7",
            "1.8.0a1",
            "1.8.0alpha",
            "1.7.6",
            "1.8.0-alpha",
            "1.7.5",
            "1.7.4",
            "1.7.3",
            "1.7.2",
            "1.7.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-62169.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:23.949849555Z",
      "provider": "osv",
      "references": [
        "https://github.com/WildRikku/OctoPrint-SpoolManager/releases/tag/1.7.8",
        "https://github.com/WildRikku/OctoPrint-SpoolManager/releases/tag/1.8.0a3",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/62xxx/CVE-2025-62169.json",
        "https://github.com/WildRikku/OctoPrint-SpoolManager/security/advisories/GHSA-2rrc-f24f-94f6",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-62169",
        "https://github.com/WildRikku/OctoPrint-SpoolManager/commit/b725e113316e177ce81238a2dbbbdb63d92c40b0"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-287"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/62xxx/CVE-2025-62169.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-62169",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 490487,
  "published_at": "2025-10-23T16:09:19.945+00:00"
}