Skip to content
Heist/ feed
Back to feed
Critical

commons-configuration2 — security advisory

Type: advisorySources: OSVAdvisory ID: UBUNTU-CVE-2022-33980

Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.

Products
commons-configuration2
Affected versions
2.2-1, 2.7-2
Fixed versions
Not specified
CVEs
CVE-2022-33980
Confirmed fixed CVEs
Not specified
Updated in this feed
28 Oct 2026, 09:08 UTC · Revision 1

Source evidence

UBUNTU-CVE-2022-33980

core-osv · Original source

Published 6 Jul 2022, 13:15 UTC

Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.

osv:UBUNTU-CVE-2022-33980

commons-configuration2

Fixed versions: Not specified

commons-configuration2

Fixed versions: Not specified

Complete source record
{
  "id": "30a82d6ee73cab45b75c394cd44da059c7ff749d87593d6ddfa787dce96f633b",
  "url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-33980",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "UBUNTU-CVE-2022-33980",
    "summary": "Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is \"${prefix:name}\", where \"prefix\" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - \"script\" - execute expressions using the JVM script execution engine (javax.script) - \"dns\" - resolve dns records - \"url\" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.",
    "evidence": "osv:UBUNTU-CVE-2022-33980",
    "products": [
      {
        "name": {
          "value": "commons-configuration2",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": [
          {
            "value": "2.2-1",
            "evidence": "/affected/0/versions"
          }
        ]
      },
      {
        "name": {
          "value": "commons-configuration2",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": [
          {
            "value": "2.7-2",
            "evidence": "/affected/1/versions"
          }
        ]
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "UBUNTU-CVE-2022-33980",
      "aliases": [
        "UBUNTU-CVE-2022-33980"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        },
        {
          "type": "Ubuntu",
          "score": "medium"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                }
              ]
            }
          ],
          "package": {
            "name": "commons-configuration2",
            "purl": "pkg:deb/ubuntu/commons-configuration2?arch=source&distro=focal",
            "ecosystem": "Ubuntu:20.04:LTS"
          },
          "versions": [
            "2.2-1"
          ],
          "database_specific": {
            "source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2022/UBUNTU-CVE-2022-33980.json"
          },
          "ecosystem_specific": {
            "binaries": [
              {
                "binary_name": "libcommons-configuration2-java",
                "binary_version": "2.2-1"
              }
            ]
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                }
              ]
            }
          ],
          "package": {
            "name": "commons-configuration2",
            "purl": "pkg:deb/ubuntu/commons-configuration2?arch=source&distro=jammy",
            "ecosystem": "Ubuntu:22.04:LTS"
          },
          "versions": [
            "2.7-2"
          ],
          "database_specific": {
            "source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2022/UBUNTU-CVE-2022-33980.json"
          },
          "ecosystem_specific": {
            "binaries": [
              {
                "binary_name": "libcommons-configuration2-java",
                "binary_version": "2.7-2"
              }
            ]
          }
        }
      ],
      "modified": "2026-10-08T12:50:27.627294041Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-33980"
      ],
      "references": [
        "https://ubuntu.com/security/CVE-2022-33980",
        "https://www.openwall.com/lists/oss-security/2022/07/06/5",
        "https://www.cve.org/CVERecord?id=CVE-2022-33980"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-33980",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 99531,
  "published_at": "2022-07-06T13:15:00+00:00"
}