Security advisory
Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an open redirect vulnerability. A maliciously crafted link to the login form and login functionality could redirect the browser to a different website. The problem has been fixed in version 2.6.1. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to `2.6.1` and re-run the buildout, or if you used `pip` simply do `pip install "Products.PluggableAuthService>=2.6.1".
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-21337
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:32 UTC · Revision 1
Source evidence
Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an open redirect vulnerability. A maliciously crafted link to the login form and login functionality could redirect the browser to a different website. The problem has been fixed in version 2.6.1. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to `2.6.1` and re-run the buildout, or if you used `pip` simply do `pip install "Products.PluggableAuthService>=2.6.1".
osv:CVE-2021-21337
Complete source record
{
"id": "32aae9b6610faf8d331972749364558448ccc8612d6865b56402c904a18c0313",
"url": "https://osv.dev/vulnerability/CVE-2021-21337",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-21337",
"summary": "Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an open redirect vulnerability. A maliciously crafted link to the login form and login functionality could redirect the browser to a different website. The problem has been fixed in version 2.6.1. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to `2.6.1` and re-run the buildout, or if you used `pip` simply do `pip install \"Products.PluggableAuthService>=2.6.1\".",
"evidence": "osv:CVE-2021-21337",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-21337",
"aliases": [
"CVE-2021-21337",
"GHSA-p44j-xrqg-4xrr",
"PYSEC-2021-45"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/zopefoundation/products.pluggableauthservice",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "2c61f577a6486759c340643d9e2efb54abf667f9"
},
{
"fixed": "7eead067898852ebd3e0f143bc51295928528dfa"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:zope:products.pluggableauthservice:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.6.1"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "7eead067898852ebd3e0f143bc51295928528dfa"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"2.6.0",
"2.5.1",
"2.4",
"2.3",
"2.2.1",
"2.2",
"2.1.1",
"2.1",
"2.0",
"2.0b6",
"2.0b5",
"2.0b4",
"2.0b3",
"1.11.0",
"2.0b2",
"2.0b1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21337.json"
}
}
],
"modified": "2026-10-20T10:54:28.226847984Z",
"provider": "osv",
"references": [
"https://github.com/zopefoundation/Products.PluggableAuthService/security/advisories/GHSA-p44j-xrqg-4xrr",
"https://github.com/zopefoundation/Products.PluggableAuthService/commit/7eead067898852ebd3e0f143bc51295928528dfa",
"https://pypi.org/project/Products.PluggableAuthService/"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-21337",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385409,
"published_at": "2021-03-08T21:15:16.807+00:00"
}