net-snmp — security advisory
net-snmp provides various tools relating to the Simple Network Management Protocol. Prior to version 5.9.2, a user with read-write credentials can exploit an Improper Input Validation vulnerability when SETing malformed OIDs in master agent and subagent simultaneously. Version 5.9.2 contains a patch. Users should use strong SNMPv3 credentials and avoid sharing the credentials. Those who must use SNMPv1 or SNMPv2c should use a complex community string and enhance the protection by restricting access to a given IP address range.
- Products
- net-snmp
- Affected versions
- Not specified
- Fixed versions
- 5.9.3+dfsg-1
- CVEs
- CVE-2022-24806
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:48 UTC · Revision 1
Source evidence
net-snmp provides various tools relating to the Simple Network Management Protocol. Prior to version 5.9.2, a user with read-write credentials can exploit an Improper Input Validation vulnerability when SETing malformed OIDs in master agent and subagent simultaneously. Version 5.9.2 contains a patch. Users should use strong SNMPv3 credentials and avoid sharing the credentials. Those who must use SNMPv1 or SNMPv2c should use a complex community string and enhance the protection by restricting access to a given IP address range.
osv:DEBIAN-CVE-2022-24806
net-snmp
Fixed versions: 5.9.3+dfsg-1
net-snmp
Fixed versions: 5.9.3+dfsg-1
net-snmp
Fixed versions: 5.9.3+dfsg-1
Complete source record
{
"id": "24c2ce9957d30314c394168fe80bf398538b3e9ff6e059784d92100e9637fab1",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-24806",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-24806",
"summary": "net-snmp provides various tools relating to the Simple Network Management Protocol. Prior to version 5.9.2, a user with read-write credentials can exploit an Improper Input Validation vulnerability when SETing malformed OIDs in master agent and subagent simultaneously. Version 5.9.2 contains a patch. Users should use strong SNMPv3 credentials and avoid sharing the credentials. Those who must use SNMPv1 or SNMPv2c should use a complex community string and enhance the protection by restricting access to a given IP address range.",
"evidence": "osv:DEBIAN-CVE-2022-24806",
"products": [
{
"name": {
"value": "net-snmp",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.9.3+dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "net-snmp",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.9.3+dfsg-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "net-snmp",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.9.3+dfsg-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2022-24806",
"aliases": [
"DEBIAN-CVE-2022-24806"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.9.3+dfsg-1"
}
]
}
],
"package": {
"name": "net-snmp",
"purl": "pkg:deb/debian/net-snmp?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-24806.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.9.3+dfsg-1"
}
]
}
],
"package": {
"name": "net-snmp",
"purl": "pkg:deb/debian/net-snmp?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-24806.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.9.3+dfsg-1"
}
]
}
],
"package": {
"name": "net-snmp",
"purl": "pkg:deb/debian/net-snmp?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-24806.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:18.583521259Z",
"provider": "osv",
"upstream": [
"CVE-2022-24806"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-24806"
]
},
"related_cves": [
{
"value": "CVE-2022-24806",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323359,
"published_at": "2024-04-16T20:15:08.413+00:00"
}