User preference to prevent private discussions not respected in fof/byobu
fof/byobu is a private discussions extension for Flarum forum. Affected versions were found to not respect private discussion disablement by users. Users of Byobu should update the extension to version 1.1.7, where this has been patched. Users of Byobu with Flarum 1.0 or 1.1 should upgrade to Flarum 1.2 or later, or evaluate the impact this issue has on your forum's users and choose to disable the extension if needed. There are no workarounds for this issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-35921
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 16:45 UTC · Revision 1
Source evidence
User preference to prevent private discussions not respected in fof/byobu
core-osv · Original sourcePublished 1 Aug 2022, 21:50 UTC
fof/byobu is a private discussions extension for Flarum forum. Affected versions were found to not respect private discussion disablement by users. Users of Byobu should update the extension to version 1.1.7, where this has been patched. Users of Byobu with Flarum 1.0 or 1.1 should upgrade to Flarum 1.2 or later, or evaluate the impact this issue has on your forum's users and choose to disable the extension if needed. There are no workarounds for this issue.
osv:CVE-2022-35921
Complete source record
{
"id": "e04fe03a14f7af7379b7bd86b608fd9dfa6c14090431310dcc3c32e2015b0ae3",
"url": "https://osv.dev/vulnerability/CVE-2022-35921",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "User preference to prevent private discussions not respected in fof/byobu",
"summary": "fof/byobu is a private discussions extension for Flarum forum. Affected versions were found to not respect private discussion disablement by users. Users of Byobu should update the extension to version 1.1.7, where this has been patched. Users of Byobu with Flarum 1.0 or 1.1 should upgrade to Flarum 1.2 or later, or evaluate the impact this issue has on your forum's users and choose to disable the extension if needed. There are no workarounds for this issue.",
"evidence": "osv:CVE-2022-35921",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2022-35921",
"aliases": [
"CVE-2022-35921",
"GHSA-6gjm-6wj6-4px5"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/friendsofflarum/byobu",
"type": "GIT",
"events": [
{
"introduced": "69efd432da6fadde1edda44d213a81388bfc6ef5"
},
{
"fixed": "bc5dafa1987b8a8b967374f6903a3cd56c08f553"
},
{
"fixed": "23dcf93a30f948d30c678a96681f7fdefeba5171"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0.3.0-beta.2"
},
{
"fixed": "1.1.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "23dcf93a30f948d30c678a96681f7fdefeba5171"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"1.1.6",
"1.1.5",
"1.1.4",
"1.1.3",
"1.1.2",
"1.1.1",
"1.1.0",
"1.0.2",
"1.0.1",
"1.0.0",
"1.0.0-beta.9",
"1.0.0-beta.8",
"1.0.0-beta.7",
"1.0.0-beta.6",
"1.0.0-beta.5",
"1.0.0-beta.4",
"1.0.0-beta.3",
"1.0.0-beta.2",
"1.0.0-beta.1",
"0.6.1",
"0.6.0",
"0.6.0-beta.3",
"0.5.6",
"0.6.0-beta.2",
"0.6.0-beta.1",
"0.5.5",
"0.5.4",
"0.5.3",
"0.5.2",
"0.5.1",
"0.5.0-beta.1",
"0.5.0",
"0.4.5",
"0.4.4",
"0.4.3",
"0.4.2",
"0.4.1",
"0.4.0",
"0.3.4",
"0.3.3",
"0.3.2",
"0.3.1",
"0.3.0",
"0.3.0-beta.3",
"0.3.0-beta.2"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-35921.json"
}
}
],
"modified": "2026-10-28T02:30:30.502256516Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/35xxx/CVE-2022-35921.json",
"https://github.com/FriendsOfFlarum/byobu/security/advisories/GHSA-6gjm-6wj6-4px5",
"https://nvd.nist.gov/vuln/detail/CVE-2022-35921",
"https://github.com/FriendsOfFlarum/byobu/commit/23dcf93a30f948d30c678a96681f7fdefeba5171"
],
"provider_metadata": {
"cwe_ids": [
"CWE-269"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/35xxx/CVE-2022-35921.json"
}
},
"related_cves": [
{
"value": "CVE-2022-35921",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 497544,
"published_at": "2022-08-01T21:50:10+00:00"
}