phpmyadmin — security advisory
Cross-site scripting (XSS) vulnerability in error.php in phpMyAdmin 2.6.4 through 2.9.0.2 allows remote attackers to inject arbitrary web script or HTML via UTF-7 or US-ASCII encoded characters, which are injected into an error message, as demonstrated by a request with a utf7 charset parameter accompanied by UTF-7 data.
- Products
- phpmyadmin
- Affected versions
- Not specified
- Fixed versions
- 4:2.9.0.3-1
- CVEs
- CVE-2006-5718
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 20:09 UTC · Revision 1
Source evidence
Cross-site scripting (XSS) vulnerability in error.php in phpMyAdmin 2.6.4 through 2.9.0.2 allows remote attackers to inject arbitrary web script or HTML via UTF-7 or US-ASCII encoded characters, which are injected into an error message, as demonstrated by a request with a utf7 charset parameter accompanied by UTF-7 data.
osv:DEBIAN-CVE-2006-5718
phpmyadmin
Fixed versions: 4:2.9.0.3-1
phpmyadmin
Fixed versions: 4:2.9.0.3-1
phpmyadmin
Fixed versions: 4:2.9.0.3-1
Complete source record
{
"id": "39c873d34a12629c4515b1522ae9a5cee5b0755e3d88302f9d6e922450dbb820",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2006-5718",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2006-5718",
"summary": "Cross-site scripting (XSS) vulnerability in error.php in phpMyAdmin 2.6.4 through 2.9.0.2 allows remote attackers to inject arbitrary web script or HTML via UTF-7 or US-ASCII encoded characters, which are injected into an error message, as demonstrated by a request with a utf7 charset parameter accompanied by UTF-7 data.",
"evidence": "osv:DEBIAN-CVE-2006-5718",
"products": [
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:2.9.0.3-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:2.9.0.3-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:2.9.0.3-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2006-5718",
"aliases": [
"DEBIAN-CVE-2006-5718"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:2.9.0.3-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-5718.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:2.9.0.3-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-5718.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:2.9.0.3-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-5718.json"
},
"ecosystem_specific": {
"urgency": "low"
}
}
],
"modified": "2026-10-22T23:47:19.825536591Z",
"provider": "osv",
"upstream": [
"CVE-2006-5718"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2006-5718"
]
},
"related_cves": [
{
"value": "CVE-2006-5718",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 410236,
"published_at": "2006-11-04T01:07:00+00:00"
}