Skip to content
Heist/ feed
Back to feed
MediumFix available

Payload: Password hashes use insufficient PBKDF2 iterations

Type: advisorySources: OSV

### Impact The password-hashing configuration used a lower work factor than what is recommended. ### Patches Payload now uses stronger password-hashing parameters and transparently upgrades older hashes following a successful login. Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds Upgrading is recommended. Until you can upgrade, protect database copies and backups from unauthorized access and require strong, unique passwords.

Products
payload
Affected versions
Not specified
Fixed versions
3.90.0, 4.0.0-canary.34
CVEs
CVE-2026-105804
Confirmed fixed CVEs
Not specified
Updated in this feed
27 Oct 2026, 11:47 UTC · Revision 1

Source evidence

Payload: Password hashes use insufficient PBKDF2 iterations

core-osv · Original source

Published 6 Oct 2026, 15:38 UTC

### Impact The password-hashing configuration used a lower work factor than what is recommended. ### Patches Payload now uses stronger password-hashing parameters and transparently upgrades older hashes following a successful login. Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds Upgrading is recommended. Until you can upgrade, protect database copies and backups from unauthorized access and require strong, unique passwords.

osv:GHSA-q6mq-ch85-c8mm

payload

Fixed versions: 3.90.0

payload

Fixed versions: 4.0.0-canary.34

Complete source record
{
  "id": "275e02174edc821821ce306a081c4d5ca11799a0f4c1fc65c1dab2523c12018d",
  "url": "https://osv.dev/vulnerability/GHSA-q6mq-ch85-c8mm",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Payload: Password hashes use insufficient PBKDF2 iterations",
    "summary": "### Impact The password-hashing configuration used a lower work factor than what is recommended. ### Patches Payload now uses stronger password-hashing parameters and transparently upgrades older hashes following a successful login. Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds Upgrading is recommended. Until you can upgrade, protect database copies and backups from unauthorized access and require strong, unique passwords.",
    "evidence": "osv:GHSA-q6mq-ch85-c8mm",
    "products": [
      {
        "name": {
          "value": "payload",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.90.0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "payload",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4.0.0-canary.34",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "GHSA-q6mq-ch85-c8mm",
      "aliases": [
        "CVE-2026-105804",
        "GHSA-q6mq-ch85-c8mm"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "3.0.0"
                },
                {
                  "fixed": "3.90.0"
                }
              ]
            }
          ],
          "package": {
            "name": "payload",
            "purl": "pkg:npm/payload",
            "ecosystem": "npm"
          },
          "database_specific": {
            "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-q6mq-ch85-c8mm/GHSA-q6mq-ch85-c8mm.json"
          }
        },
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "4.0.0-canary.0"
                },
                {
                  "fixed": "4.0.0-canary.34"
                }
              ]
            }
          ],
          "package": {
            "name": "payload",
            "purl": "pkg:npm/payload",
            "ecosystem": "npm"
          },
          "database_specific": {
            "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-q6mq-ch85-c8mm/GHSA-q6mq-ch85-c8mm.json"
          }
        }
      ],
      "modified": "2026-10-06T15:46:47.684356483Z",
      "provider": "osv",
      "references": [
        "https://github.com/payloadcms/payload/security/advisories/GHSA-q6mq-ch85-c8mm",
        "https://github.com/payloadcms/payload/commit/1bc76e540a10f3ec88340f40591a57dae7456d01",
        "https://github.com/payloadcms/payload",
        "https://github.com/payloadcms/payload/releases/tag/v3.90.0"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-916"
        ],
        "severity": "MODERATE",
        "github_reviewed": true,
        "nvd_published_at": null,
        "github_reviewed_at": "2026-10-06T15:38:37Z"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-105804",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 89264,
  "published_at": "2026-10-06T15:38:37+00:00"
}