Apache RocketMQ: Possible remote code execution vulnerability when using the update configuration function
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content. To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-33246
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 06:13 UTC · Revision 1
Source evidence
Apache RocketMQ: Possible remote code execution vulnerability when using the update configuration function
core-osv · Original sourcePublished 24 May 2023, 14:45 UTC
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content. To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .
osv:CVE-2023-33246
Complete source record
{
"id": "06c429022c1266177288dcad18c8bc1d0fce6a5e37b7878829bf07a03f547dd5",
"url": "https://osv.dev/vulnerability/CVE-2023-33246",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache RocketMQ: Possible remote code execution vulnerability when using the update configuration function",
"summary": "For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content. To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .",
"evidence": "osv:CVE-2023-33246",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2023-33246",
"aliases": [
"CVE-2023-33246",
"GHSA-x3cq-8f32-5f63"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/rocketmq",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "db4ba459bec9392ac37647ff1a4d24d30466814d"
},
{
"introduced": "f3e113cb1f98ced8327e7c97bfb5a623950339ef"
},
{
"fixed": "e244ebb99a1ba5e5dac174c699da8b83a273e7fd"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:rocketmq:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.9.6"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:apache:rocketmq:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "5.0.0"
},
{
"fixed": "5.1.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"rocketmq-all-4.9.5",
"rocketmq-all-5.1.0",
"rocketmq-all-4.9.4",
"rocketmq-all-4.9.3",
"rocketmq-all-4.9.2",
"rocketmq-all-4.9.1",
"rocketmq-all-4.9.0",
"rocketmq-all-4.8.0",
"rocketmq-all-4.7.1",
"rocketmq-all-4.7.0",
"rocketmq-all-4.6.0",
"rocketmq-all-4.6.1",
"rocketmq-all-4.5.2",
"rocketmq-all-4.5.1",
"rocketmq-all-4.4.0",
"rocketmq-all-4.2.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-33246.json"
}
}
],
"modified": "2026-10-28T02:30:42.936799933Z",
"provider": "osv",
"references": [
"https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-33246",
"https://www.vicarius.io/vsociety/posts/rocketmq-rce-cve-2023-33246-33247",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/33xxx/CVE-2023-33246.json",
"https://lists.apache.org/thread/1s8j2c8kogthtpv3060yddk03zq0pxyp",
"https://nvd.nist.gov/vuln/detail/CVE-2023-33246",
"https://github.com/Malayke/CVE-2023-33246_RocketMQ_RCE_EXPLOIT",
"https://github.com/jakabakos/CVE-2023-33246_Apache_RocketMQ_RCE"
],
"provider_metadata": {
"cwe_ids": [
"CWE-94"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "5.1.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/33xxx/CVE-2023-33246.json"
}
},
"related_cves": [
{
"value": "CVE-2023-33246",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 510987,
"published_at": "2023-05-24T14:45:25.684+00:00"
}