Low
Security advisory
The package `node-cli` before 1.0.0 insecurely uses the lock_file and log_file. Both of these are temporary, but it allows the starting user to overwrite any file they have access to.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2016-10538
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 17:40 UTC · Revision 1
Source evidence
The package `node-cli` before 1.0.0 insecurely uses the lock_file and log_file. Both of these are temporary, but it allows the starting user to overwrite any file they have access to.
osv:CVE-2016-10538
Complete source record
{
"id": "65a75d222d73442310fb95e3899e01b8259334917d8b2bb4aed78e616ad5b9aa",
"url": "https://osv.dev/vulnerability/CVE-2016-10538",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2016-10538",
"summary": "The package `node-cli` before 1.0.0 insecurely uses the lock_file and log_file. Both of these are temporary, but it allows the starting user to overwrite any file they have access to.",
"evidence": "osv:CVE-2016-10538",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2016-10538",
"aliases": [
"CVE-2016-10538",
"GHSA-6cpc-mj5c-m9rq"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/node-js-libs/cli",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "969a1e58748cb057d41835ef8ec9f5b99d1560a7"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:cli_project:cli:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.0.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"0.11.3",
"0.11.2",
"0.11.1",
"0.11.0",
"0.9.0",
"0.8.0",
"0.7.1",
"0.7.0",
"0.6.6",
"0.6.5",
"0.6.4",
"0.6.3",
"0.6.2",
"0.6.1",
"0.6.0",
"0.5.0",
"0.4.5"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-10538.json"
}
}
],
"modified": "2026-10-22T02:46:20.020873490Z",
"provider": "osv",
"references": [
"https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809252",
"https://github.com/node-js-libs/cli/issues/81",
"https://nodesecurity.io/advisories/95"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2016-10538",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 404281,
"published_at": "2018-05-31T20:29:01.363+00:00"
}