Skip to content
Heist/ feed
Back to feed
CriticalFix available

Payload: Unauthorized update to collection documents

Type: advisorySources: OSV

## Impact An attacker can submit a request to a specific endpoint that permits collection documents to be updated regardless of access control and field level access control. **You are affected if:** - You are configuring `orderable: true` with any collection or join field. ## Patches In the patched version access control is properly enforced. Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`.

Products
payload
Affected versions
Not specified
Fixed versions
3.90.0, 4.0.0-canary.34
CVEs
CVE-2026-105859
Confirmed fixed CVEs
Not specified
Updated in this feed
28 Oct 2026, 08:48 UTC · Revision 1

Source evidence

Payload: Unauthorized update to collection documents

core-osv · Original source

Published 7 Oct 2026, 20:28 UTC

## Impact An attacker can submit a request to a specific endpoint that permits collection documents to be updated regardless of access control and field level access control. **You are affected if:** - You are configuring `orderable: true` with any collection or join field. ## Patches In the patched version access control is properly enforced. Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`.

osv:GHSA-f7hx-52q9-hcrf

payload

Fixed versions: 3.90.0

payload

Fixed versions: 4.0.0-canary.34

Complete source record
{
  "id": "f6a27cb3044ad47aaaf3942b88acc0c85aaefaa8829a4ef8dbd099ed0bda1776",
  "url": "https://osv.dev/vulnerability/GHSA-f7hx-52q9-hcrf",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Payload: Unauthorized update to collection documents",
    "summary": "## Impact An attacker can submit a request to a specific endpoint that permits collection documents to be updated regardless of access control and field level access control. **You are affected if:** - You are configuring `orderable: true` with any collection or join field. ## Patches In the patched version access control is properly enforced. Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`.",
    "evidence": "osv:GHSA-f7hx-52q9-hcrf",
    "products": [
      {
        "name": {
          "value": "payload",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.90.0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "payload",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4.0.0-canary.34",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "GHSA-f7hx-52q9-hcrf",
      "aliases": [
        "CVE-2026-105859",
        "GHSA-f7hx-52q9-hcrf"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3.90.0"
                }
              ]
            }
          ],
          "package": {
            "name": "payload",
            "purl": "pkg:npm/payload",
            "ecosystem": "npm"
          },
          "database_specific": {
            "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-f7hx-52q9-hcrf/GHSA-f7hx-52q9-hcrf.json"
          }
        },
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "4.0.0-canary.0"
                },
                {
                  "fixed": "4.0.0-canary.34"
                }
              ]
            }
          ],
          "package": {
            "name": "payload",
            "purl": "pkg:npm/payload",
            "ecosystem": "npm"
          },
          "database_specific": {
            "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-f7hx-52q9-hcrf/GHSA-f7hx-52q9-hcrf.json"
          }
        }
      ],
      "modified": "2026-10-07T20:45:05.336033588Z",
      "provider": "osv",
      "references": [
        "https://github.com/payloadcms/payload/security/advisories/GHSA-f7hx-52q9-hcrf",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-105859",
        "https://github.com/payloadcms/payload/commit/36fa9af73dd04fa59f4b4a06d11454538c4c1409",
        "https://github.com/payloadcms/payload",
        "https://github.com/payloadcms/payload/releases/tag/v3.90.0"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-639",
          "CWE-862"
        ],
        "severity": "CRITICAL",
        "github_reviewed": true,
        "nvd_published_at": "2026-10-06T17:17:21Z",
        "github_reviewed_at": "2026-10-07T20:28:27Z"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-105859",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 97263,
  "published_at": "2026-10-07T20:28:27+00:00"
}