Skip to content
Heist/ feed
Back to feed
Medium

WPZOOM Addons for Elementor (Templates, Widgets) <= 1.1.36 - Authenticated (Contributor+) Stored Cross-Site Scripting via Image Box Widget

Type: advisorySources: OSV

The WPZOOM Addons for Elementor (Templates, Widgets) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's widget Image Box in all versions up to, and including, 1.1.36 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-4370
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 15:57 UTC · Revision 1

Source evidence

WPZOOM Addons for Elementor (Templates, Widgets) <= 1.1.36 - Authenticated (Contributor+) Stored Cross-Site Scripting via Image Box Widget

core-osv · Original source

Published 14 May 2024, 23:31 UTC

The WPZOOM Addons for Elementor (Templates, Widgets) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's widget Image Box in all versions up to, and including, 1.1.36 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

osv:CVE-2024-4370
Complete source record
{
  "id": "90750fe0f9e7455149aeb29db0b63e84d54bca1a5abe714b2b239508e17ca3a4",
  "url": "https://osv.dev/vulnerability/CVE-2024-4370",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "WPZOOM Addons for Elementor (Templates, Widgets) <= 1.1.36 - Authenticated (Contributor+) Stored Cross-Site Scripting via Image Box Widget",
    "summary": "The WPZOOM Addons for Elementor (Templates, Widgets) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's widget Image Box in all versions up to, and including, 1.1.36 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
    "evidence": "osv:CVE-2024-4370",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2024-4370",
      "aliases": [
        "CVE-2024-4370"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wpzoom/wpzoom-elementor-addons",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5d160d00db165f71e4fa0a447c1dc187f991eee2"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wpzoom:wpzoom_elementor_addons:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.1.37"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.1.36",
            "1.1.35",
            "1.1.34",
            "1.1.33",
            "1.1.32",
            "1.1.31",
            "1.1.30",
            "1.1.29",
            "1.1.28",
            "1.1.27",
            "1.1.26",
            "1.1.25",
            "1.1.24",
            "1.1.23",
            "1.1.22",
            "1.1.21",
            "1.1.20",
            "1.1.19",
            "1.1.18",
            "1.1.17",
            "1.1.16",
            "1.1.15"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-4370.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:36.879753763Z",
      "provider": "osv",
      "references": [
        "https://plugins.trac.wordpress.org/browser/wpzoom-elementor-addons/trunk/includes/widgets/image-box/image-box.php#L1229",
        "https://plugins.trac.wordpress.org/changeset/3084540",
        "https://wordpress.org/plugins/wpzoom-elementor-addons/#developers",
        "https://www.wordfence.com/threat-intel/vulnerabilities/id/c7aaff3e-0c81-4fe7-b162-569c517f6c49?source=cve",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/4xxx/CVE-2024-4370.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-4370"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "Wordfence",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "1.1.36"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/4xxx/CVE-2024-4370.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-4370",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 504366,
  "published_at": "2024-05-14T23:31:46.023+00:00"
}