Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-23392

The package locutus before 2.0.15 are vulnerable to Regular Expression Denial of Service (ReDoS) via the gopher_parsedir function.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-23392
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:40 UTC · Revision 1

Source evidence

CVE-2021-23392

core-osv · Original source

Published 8 Jun 2021, 08:15 UTC

The package locutus before 2.0.15 are vulnerable to Regular Expression Denial of Service (ReDoS) via the gopher_parsedir function.

osv:CVE-2021-23392
Complete source record
{
  "id": "bafcb6be5fe21213f02609ba7bf575cd29be9c6d8ad28021b79d8b8ef58f92ad",
  "url": "https://osv.dev/vulnerability/CVE-2021-23392",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-23392",
    "summary": "The package locutus before 2.0.15 are vulnerable to Regular Expression Denial of Service (ReDoS) via the gopher_parsedir function.",
    "evidence": "osv:CVE-2021-23392",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2021-23392",
      "aliases": [
        "CVE-2021-23392",
        "GHSA-39q4-p535-c852",
        "SNYK-JS-LOCUTUS-1090597"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/locutusjs/locutus",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "58b29f92c870cdba84a0c5aef37ce2f2a774a3aa"
                },
                {
                  "fixed": "eb863321990e7e5514aa14f68b8d9978ece9e65e"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:locutus:locutus:*:*:*:*:*:node.js:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.0.15"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "eb863321990e7e5514aa14f68b8d9978ece9e65e"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.0.14",
            "v2.0.13",
            "v2.0.12",
            "v2.0.11",
            "v2.0.10",
            "v2.0.9",
            "v2.0.8",
            "v2.0.7",
            "v2.0.6",
            "v2.0.5",
            "v2.0.4",
            "v2.0.3",
            "v2.0.2",
            "v2.0.1",
            "v2.0.0",
            "v1.3.2"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-23392.json"
          }
        }
      ],
      "modified": "2026-10-20T10:54:31.999446480Z",
      "provider": "osv",
      "references": [
        "https://github.com/locutusjs/locutus/commit/eb863321990e7e5514aa14f68b8d9978ece9e65e",
        "https://github.com/locutusjs/locutus/pull/446",
        "https://snyk.io/vuln/SNYK-JS-LOCUTUS-1090597"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2021-23392",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 385496,
  "published_at": "2021-06-08T08:15:06.98+00:00"
}