TYPO3 CMS Vulnerable to Privilege Escalation to System Maintainer
TYPO3 is an open source, PHP based web content management system. Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. Users should update to TYPO3 version 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-47940
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 06:31 UTC · Revision 1
Source evidence
TYPO3 CMS Vulnerable to Privilege Escalation to System Maintainer
core-osv · Original sourcePublished 20 May 2025, 14:06 UTC
TYPO3 is an open source, PHP based web content management system. Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. Users should update to TYPO3 version 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.
osv:CVE-2025-47940
Complete source record
{
"id": "409f28145365c032b0729523cb8c589a2b33905027f552c78034a45057f6c699",
"url": "https://osv.dev/vulnerability/CVE-2025-47940",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "TYPO3 CMS Vulnerable to Privilege Escalation to System Maintainer",
"summary": "TYPO3 is an open source, PHP based web content management system. Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. Users should update to TYPO3 version 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.",
"evidence": "osv:CVE-2025-47940",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-47940",
"aliases": [
"CVE-2025-47940",
"GHSA-6frx-j292-c844"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/typo3/typo3",
"type": "GIT",
"events": [
{
"introduced": "36096733dea4bd6f6168209609fa879dc25c0138"
},
{
"fixed": "1f80000d7c594d2333efd2bef2f842338a0115a6"
},
{
"introduced": "fd8745e46bb11773e85524b8ee9650dabe340713"
},
{
"fixed": "812e327a74813bdb07d19cde3076d3d41b8ca4cf"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:typo3:typo3:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "12.0.0"
},
{
"fixed": "12.4.31"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:typo3:typo3:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "13.0.0"
},
{
"fixed": "13.4.12"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v13.4.11",
"v12.4.30",
"v13.4.10",
"v12.4.29",
"v13.4.9",
"v13.4.8",
"v12.4.28",
"v13.4.7",
"v13.4.6",
"v13.4.5",
"v12.4.27",
"v13.4.4",
"v12.4.26",
"v13.4.3",
"v12.4.25",
"v13.4.2",
"v12.4.24",
"v13.4.1",
"v12.4.23",
"v12.4.22",
"v13.4.0",
"v12.4.21",
"v13.3.0",
"v12.4.20",
"v12.4.19",
"v12.4.18",
"v12.4.17",
"v13.2.1",
"v13.2.0",
"v12.4.16",
"v12.4.15",
"v13.1.0",
"v12.4.14",
"v12.4.13",
"v12.4.12",
"v12.4.11",
"v13.0.0",
"v12.4.10",
"v12.4.9",
"v12.4.8",
"v12.4.7",
"v12.4.6",
"v12.4.5",
"v12.4.4",
"v12.4.3",
"v12.4.2",
"v12.4.1",
"v12.4.0",
"v12.3.0",
"v12.2.0",
"v12.1.0",
"v12.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-47940.json"
}
}
],
"modified": "2026-10-28T02:30:26.444169207Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/47xxx/CVE-2025-47940.json",
"https://github.com/TYPO3/typo3/security/advisories/GHSA-6frx-j292-c844",
"https://nvd.nist.gov/vuln/detail/CVE-2025-47940",
"https://typo3.org/security/advisory/typo3-core-sa-2025-016"
],
"provider_metadata": {
"cwe_ids": [
"CWE-283"
],
"cna_assigner": "GitHub_M",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "10.0.0"
},
{
"fixed": "10.4.50"
},
{
"introduced": "11.0.0"
},
{
"fixed": "11.5.44"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/47xxx/CVE-2025-47940.json"
}
},
"related_cves": [
{
"value": "CVE-2025-47940",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 493070,
"published_at": "2025-05-20T14:06:07.374+00:00"
}