UnratedFix available
phpmyadmin — security advisory
Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.8.0.x before 2.8.0.4 allows remote attackers to inject arbitrary web script or HTML via the theme parameter in unknown scripts. NOTE: the lang parameter is already covered by CVE-2006-2031.
- Products
- phpmyadmin
- Affected versions
- Not specified
- Fixed versions
- 4:2.8.1-1
- CVEs
- CVE-2006-2417
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 20:10 UTC · Revision 1
Source evidence
Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.8.0.x before 2.8.0.4 allows remote attackers to inject arbitrary web script or HTML via the theme parameter in unknown scripts. NOTE: the lang parameter is already covered by CVE-2006-2031.
osv:DEBIAN-CVE-2006-2417
phpmyadmin
Fixed versions: 4:2.8.1-1
phpmyadmin
Fixed versions: 4:2.8.1-1
phpmyadmin
Fixed versions: 4:2.8.1-1
Complete source record
{
"id": "a40aeef1d0c032b21dbec8bb539a445a29c573eb43b52cbc8f7c329da4a97300",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2006-2417",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2006-2417",
"summary": "Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.8.0.x before 2.8.0.4 allows remote attackers to inject arbitrary web script or HTML via the theme parameter in unknown scripts. NOTE: the lang parameter is already covered by CVE-2006-2031.",
"evidence": "osv:DEBIAN-CVE-2006-2417",
"products": [
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:2.8.1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:2.8.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:2.8.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2006-2417",
"aliases": [
"DEBIAN-CVE-2006-2417"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:2.8.1-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-2417.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:2.8.1-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-2417.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:2.8.1-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-2417.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
}
],
"modified": "2026-10-22T23:47:21.796188221Z",
"provider": "osv",
"upstream": [
"CVE-2006-2417"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2006-2417"
]
},
"related_cves": [
{
"value": "CVE-2006-2417",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 410323,
"published_at": "2006-05-16T10:02:00+00:00"
}