Fast DDS does not verify Permissions CA
eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2, and 3.2.0, per design, PermissionsCA is not full chain validated, nor is the expiration date validated. Access control plugin validates only the S/MIME signature which causes an expired PermissionsCA to be taken as valid. Even though this issue is responsible for allowing `governance/permissions` from an expired PermissionsCA and having the system crash when PermissionsCA is not self-signed and contains the full-chain, the impact is low. Versions 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2, and 3.2.0 contain a fix for the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-24807
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 02:28 UTC · Revision 1
Source evidence
eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2, and 3.2.0, per design, PermissionsCA is not full chain validated, nor is the expiration date validated. Access control plugin validates only the S/MIME signature which causes an expired PermissionsCA to be taken as valid. Even though this issue is responsible for allowing `governance/permissions` from an expired PermissionsCA and having the system crash when PermissionsCA is not self-signed and contains the full-chain, the impact is low. Versions 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2, and 3.2.0 contain a fix for the issue.
osv:CVE-2025-24807
Complete source record
{
"id": "311d2040b8afa1c4f502688f95ab959ba668adbba7c5eb932294d3db29e9d064",
"url": "https://osv.dev/vulnerability/CVE-2025-24807",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Fast DDS does not verify Permissions CA",
"summary": "eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2, and 3.2.0, per design, PermissionsCA is not full chain validated, nor is the expiration date validated. Access control plugin validates only the S/MIME signature which causes an expired PermissionsCA to be taken as valid. Even though this issue is responsible for allowing `governance/permissions` from an expired PermissionsCA and having the system crash when PermissionsCA is not self-signed and contains the full-chain, the impact is low. Versions 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2, and 3.2.0 contain a fix for the issue.",
"evidence": "osv:CVE-2025-24807",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-24807",
"aliases": [
"CVE-2025-24807",
"GHSA-w33g-jmm2-8983"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:U"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/eprosima/fast-dds",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "33e1d9cd5bf9c142c95d545c6ce45727ff599076"
},
{
"introduced": "463d59ca81c7fd732edf45b982a58c0b54fc1da4"
},
{
"fixed": "92a890c1dea08682d2fc83974d96cebc4b7feb9b"
},
{
"introduced": "4c2016660e7d6a6e94970e1a2b4dcd8e47f21581"
},
{
"fixed": "ebcb5c05e9da9e262041e8616bbaff61ab40a296"
},
{
"introduced": "c53cd0a425e6f5483fbd971eb584b4360c306891"
},
{
"fixed": "6460f2d8e2e0782f258c6a9fd6857a97d996d2fc"
},
{
"introduced": "e2afc1526f08bd949964814f7f935b3eae8858a9"
},
{
"fixed": "1be2a852cfc63f70d490fbc9a21a93e01ee41efc"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:eprosima:fast_dds:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.6.10"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:eprosima:fast_dds:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.10.0"
},
{
"fixed": "2.10.7"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:eprosima:fast_dds:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.14.0"
},
{
"fixed": "2.14.5"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:eprosima:fast_dds:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.0.2"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:eprosima:fast_dds:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.1.0"
},
{
"fixed": "3.1.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.10.1-rc1",
"v2.10.0-rc1",
"v2.3.0-1",
"v2.3.0-api",
"v2.2.0",
"v2.1.0",
"2.0.0-rc",
"2.0.0-beta",
"v1.7.2",
"Discovery-Time_Data_Typing",
"v1.9.0",
"v1.9.0-beta-2",
"v1.9.0-beta",
"v1.8.0-2",
"v1.8.0",
"v1.7.1",
"v1.7.0",
"v1.6.0",
"v1.5.0",
"v1.4.0",
"v1.3.0",
"v1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-24807.json"
}
}
],
"modified": "2026-10-28T02:30:25.573181608Z",
"provider": "osv",
"references": [
"https://github.com/eProsima/Fast-DDS/blob/2.6.9/src/cpp/security/accesscontrol/Permissions.cpp#L390-L396",
"https://github.com/eProsima/Fast-DDS/blob/2.6.9/src/cpp/security/accesscontrol/Permissions.cpp#L412",
"https://github.com/eProsima/Fast-DDS/blob/2.6.9/src/cpp/security/authentication/PKIDH.cpp#L241",
"https://www.omg.org/spec/DDS-SECURITY/1.1/PDF",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/24xxx/CVE-2025-24807.json",
"https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-w33g-jmm2-8983",
"https://nvd.nist.gov/vuln/detail/CVE-2025-24807",
"https://github.com/eProsima/Fast-DDS/pull/5530"
],
"provider_metadata": {
"cwe_ids": [
"CWE-345"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/24xxx/CVE-2025-24807.json"
}
},
"related_cves": [
{
"value": "CVE-2025-24807",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491858,
"published_at": "2025-02-11T15:31:50.337+00:00"
}