qemu — security advisory
An integer overflow was found in the QEMU implementation of VMWare's paravirtual RDMA device in versions prior to 6.1.0. The issue occurs while handling a "PVRDMA_REG_DSRHIGH" write from the guest due to improper input validation. This flaw allows a privileged guest user to make QEMU allocate a large amount of memory, resulting in a denial of service. The highest threat from this vulnerability is to system availability.
- Products
- qemu
- Affected versions
- Not specified
- Fixed versions
- 1:5.2+dfsg-11
- CVEs
- CVE-2021-3607
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:24 UTC · Revision 1
Source evidence
An integer overflow was found in the QEMU implementation of VMWare's paravirtual RDMA device in versions prior to 6.1.0. The issue occurs while handling a "PVRDMA_REG_DSRHIGH" write from the guest due to improper input validation. This flaw allows a privileged guest user to make QEMU allocate a large amount of memory, resulting in a denial of service. The highest threat from this vulnerability is to system availability.
osv:DEBIAN-CVE-2021-3607
qemu
Fixed versions: 1:5.2+dfsg-11
qemu
Fixed versions: 1:5.2+dfsg-11
qemu
Fixed versions: 1:5.2+dfsg-11
Complete source record
{
"id": "9d319159431a338afd77f480a8280d136f841aa221d441e33678f5af6855a9d8",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-3607",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-3607",
"summary": "An integer overflow was found in the QEMU implementation of VMWare's paravirtual RDMA device in versions prior to 6.1.0. The issue occurs while handling a \"PVRDMA_REG_DSRHIGH\" write from the guest due to improper input validation. This flaw allows a privileged guest user to make QEMU allocate a large amount of memory, resulting in a denial of service. The highest threat from this vulnerability is to system availability.",
"evidence": "osv:DEBIAN-CVE-2021-3607",
"products": [
{
"name": {
"value": "qemu",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:5.2+dfsg-11",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "qemu",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:5.2+dfsg-11",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "qemu",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:5.2+dfsg-11",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2021-3607",
"aliases": [
"DEBIAN-CVE-2021-3607"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:5.2+dfsg-11"
}
]
}
],
"package": {
"name": "qemu",
"purl": "pkg:deb/debian/qemu?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-3607.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:5.2+dfsg-11"
}
]
}
],
"package": {
"name": "qemu",
"purl": "pkg:deb/debian/qemu?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-3607.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:5.2+dfsg-11"
}
]
}
],
"package": {
"name": "qemu",
"purl": "pkg:deb/debian/qemu?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-3607.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:16.125903128Z",
"provider": "osv",
"upstream": [
"CVE-2021-3607"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-3607"
]
},
"related_cves": [
{
"value": "CVE-2021-3607",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 420987,
"published_at": "2022-02-24T19:15:09.113+00:00"
}