High
Security advisory
An authenticated user can execute ALTER TABLE EXCHANGE PARTITIONS without being authorized by Apache Sentry before 2.0.1. This can allow an attacker unauthorized access to the partitioned data of a Sentry protected table and can allow an attacker to remove data from a Sentry protected table.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-8028
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 06:45 UTC · Revision 1
Source evidence
An authenticated user can execute ALTER TABLE EXCHANGE PARTITIONS without being authorized by Apache Sentry before 2.0.1. This can allow an attacker unauthorized access to the partitioned data of a Sentry protected table and can allow an attacker to remove data from a Sentry protected table.
osv:CVE-2018-8028
Complete source record
{
"id": "d115293ff15c4d335b7d98c4c854c1493d81ff54a9d4314f285186950d203e0b",
"url": "https://osv.dev/vulnerability/CVE-2018-8028",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-8028",
"summary": "An authenticated user can execute ALTER TABLE EXCHANGE PARTITIONS without being authorized by Apache Sentry before 2.0.1. This can allow an attacker unauthorized access to the partitioned data of a Sentry protected table and can allow an attacker to remove data from a Sentry protected table.",
"evidence": "osv:CVE-2018-8028",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2018-8028",
"aliases": [
"CVE-2018-8028",
"GHSA-6xhj-p29v-82j8"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/sentry",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "a8954b221945154a43dd2a3180de909555310f85"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:sentry:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.0.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"release-2.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-8028.json"
}
}
],
"modified": "2026-10-24T10:30:44.101288928Z",
"provider": "osv",
"references": [
"https://cwiki.apache.org/confluence/display/SENTRY/Vulnerabilities+found+in+Apache+Sentry"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2018-8028",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 435789,
"published_at": "2018-08-23T15:29:01.88+00:00"
}