Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2016-3098

Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth autorization code.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2016-3098
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 06:28 UTC · Revision 1

Source evidence

CVE-2016-3098

core-osv · Original source

Published 5 Aug 2022, 16:15 UTC

Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth autorization code.

osv:CVE-2016-3098
Complete source record
{
  "id": "65b710e607ab6953d234a7d990cd55976267fcd0ed3366ccfa1a12a2187e3b6e",
  "url": "https://osv.dev/vulnerability/CVE-2016-3098",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2016-3098",
    "summary": "Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth autorization code.",
    "evidence": "osv:CVE-2016-3098",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2016-3098",
      "aliases": [
        "CVE-2016-3098",
        "GHSA-cc8c-26rj-v2vx"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/thoughtbot/administrate",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "463af26c1fb4e4cfd1ddb4f1c0bb5a2fcfba6471"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:thoughtbot:administrate:*:*:*:*:*:ruby:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "0.1.5"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v0.1.4",
            "v0.1.3",
            "v0.1.2",
            "v0.1.1",
            "v0.1.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-3098.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:39.951046099Z",
      "provider": "osv",
      "references": [
        "https://seclists.org/oss-sec/2016/q2/0"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2016-3098",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 434792,
  "published_at": "2022-08-05T16:15:09.653+00:00"
}