gss-ntlmssp — security advisory
GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, a memory leak can be triggered when parsing usernames which can trigger a denial-of-service. The domain portion of a username may be overridden causing an allocated memory area the size of the domain name to be leaked. An attacker can leak memory via the main `gss_accept_sec_context` entry point, potentially causing a denial-of-service. This issue is fixed in version 1.2.0.
- Products
- gss-ntlmssp
- Affected versions
- Not specified
- Fixed versions
- 1.2.0-1
- CVEs
- CVE-2023-25566
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 15:27 UTC · Revision 1
Source evidence
GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, a memory leak can be triggered when parsing usernames which can trigger a denial-of-service. The domain portion of a username may be overridden causing an allocated memory area the size of the domain name to be leaked. An attacker can leak memory via the main `gss_accept_sec_context` entry point, potentially causing a denial-of-service. This issue is fixed in version 1.2.0.
osv:DEBIAN-CVE-2023-25566
gss-ntlmssp
Fixed versions: 1.2.0-1
gss-ntlmssp
Fixed versions: 1.2.0-1
gss-ntlmssp
Fixed versions: 1.2.0-1
Complete source record
{
"id": "2260464a3682afdab98388f23cb73dc9299f3443e0878a1d84e8ecc2e6625b2d",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-25566",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-25566",
"summary": "GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, a memory leak can be triggered when parsing usernames which can trigger a denial-of-service. The domain portion of a username may be overridden causing an allocated memory area the size of the domain name to be leaked. An attacker can leak memory via the main `gss_accept_sec_context` entry point, potentially causing a denial-of-service. This issue is fixed in version 1.2.0.",
"evidence": "osv:DEBIAN-CVE-2023-25566",
"products": [
{
"name": {
"value": "gss-ntlmssp",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.2.0-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "gss-ntlmssp",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.2.0-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "gss-ntlmssp",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.2.0-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-25566",
"aliases": [
"DEBIAN-CVE-2023-25566"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.0-1"
}
]
}
],
"package": {
"name": "gss-ntlmssp",
"purl": "pkg:deb/debian/gss-ntlmssp?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-25566.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.0-1"
}
]
}
],
"package": {
"name": "gss-ntlmssp",
"purl": "pkg:deb/debian/gss-ntlmssp?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-25566.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.0-1"
}
]
}
],
"package": {
"name": "gss-ntlmssp",
"purl": "pkg:deb/debian/gss-ntlmssp?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-25566.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:00:37.912881988Z",
"provider": "osv",
"upstream": [
"CVE-2023-25566"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-25566"
]
},
"related_cves": [
{
"value": "CVE-2023-25566",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 455106,
"published_at": "2023-02-14T18:15:13.38+00:00"
}