facter, puppet — security advisory
Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with Ruby 1.9.1 or earlier, allows local users to gain privileges via a Trojan horse file in the current working directory, as demonstrated using (1) rubygems/defaults/operating_system.rb, (2) Win32API.rb, (3) Win32API.so, (4) safe_yaml.rb, (5) safe_yaml/deep.rb, or (6) safe_yaml/deep.so; or (7) operatingsystem.rb, (8) operatingsystem.so, (9) osfamily.rb, or (10) osfamily.so in puppet/confine.
- Products
- facter, puppet
- Affected versions
- 1.7.0-1ubuntu1, 1.7.2-1ubuntu1, 1.7.3-1ubuntu1, 1.7.5-1ubuntu1, 3.2.4-2ubuntu2, 3.3.1-1ubuntu1, 3.3.1-1ubuntu2, 3.3.1-1ubuntu3, 3.4.2-1, 3.4.3-1, 3.4.3-1ubuntu1, 3.4.3-1ubuntu1.1, 4.10.0-1build1
- Fixed versions
- 3.4.3-1ubuntu1.2
- CVEs
- CVE-2014-3248
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 00:20 UTC · Revision 1
Source evidence
Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with Ruby 1.9.1 or earlier, allows local users to gain privileges via a Trojan horse file in the current working directory, as demonstrated using (1) rubygems/defaults/operating_system.rb, (2) Win32API.rb, (3) Win32API.so, (4) safe_yaml.rb, (5) safe_yaml/deep.rb, or (6) safe_yaml/deep.so; or (7) operatingsystem.rb, (8) operatingsystem.so, (9) osfamily.rb, or (10) osfamily.so in puppet/confine.
osv:UBUNTU-CVE-2014-3248
puppet
Fixed versions: 3.4.3-1ubuntu1.2
facter
Fixed versions: Not specified
facter
Fixed versions: Not specified
Complete source record
{
"id": "08081570393c1588d6a1b4877491fe70506cd9053df3f7a685669a41e5a5170e",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2014-3248",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2014-3248",
"summary": "Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with Ruby 1.9.1 or earlier, allows local users to gain privileges via a Trojan horse file in the current working directory, as demonstrated using (1) rubygems/defaults/operating_system.rb, (2) Win32API.rb, (3) Win32API.so, (4) safe_yaml.rb, (5) safe_yaml/deep.rb, or (6) safe_yaml/deep.so; or (7) operatingsystem.rb, (8) operatingsystem.so, (9) osfamily.rb, or (10) osfamily.so in puppet/confine.",
"evidence": "osv:UBUNTU-CVE-2014-3248",
"products": [
{
"name": {
"value": "puppet",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.4.3-1ubuntu1.2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "3.2.4-2ubuntu2",
"evidence": "/affected/0/versions"
},
{
"value": "3.3.1-1ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "3.3.1-1ubuntu2",
"evidence": "/affected/0/versions"
},
{
"value": "3.3.1-1ubuntu3",
"evidence": "/affected/0/versions"
},
{
"value": "3.4.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.4.3-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.4.3-1ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "3.4.3-1ubuntu1.1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "facter",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.7.0-1ubuntu1",
"evidence": "/affected/1/versions"
},
{
"value": "1.7.2-1ubuntu1",
"evidence": "/affected/1/versions"
},
{
"value": "1.7.3-1ubuntu1",
"evidence": "/affected/1/versions"
},
{
"value": "1.7.5-1ubuntu1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "facter",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.10.0-1build1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "unknown",
"structured": {
"id": "UBUNTU-CVE-2014-3248",
"aliases": [
"UBUNTU-CVE-2014-3248"
],
"metrics": [
{
"type": "Ubuntu",
"score": "low"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.3-1ubuntu1.2"
}
]
}
],
"package": {
"name": "puppet",
"purl": "pkg:deb/ubuntu/puppet?arch=source&distro=trusty",
"ecosystem": "Ubuntu:14.04:LTS"
},
"versions": [
"3.2.4-2ubuntu2",
"3.3.1-1ubuntu1",
"3.3.1-1ubuntu2",
"3.3.1-1ubuntu3",
"3.4.2-1",
"3.4.3-1",
"3.4.3-1ubuntu1",
"3.4.3-1ubuntu1.1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2014/UBUNTU-CVE-2014-3248.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "puppet",
"binary_version": "3.4.3-1ubuntu1.2"
},
{
"binary_name": "puppet-common",
"binary_version": "3.4.3-1ubuntu1.2"
},
{
"binary_name": "puppet-el",
"binary_version": "3.4.3-1ubuntu1.2"
},
{
"binary_name": "puppet-testsuite",
"binary_version": "3.4.3-1ubuntu1.2"
},
{
"binary_name": "puppetmaster",
"binary_version": "3.4.3-1ubuntu1.2"
},
{
"binary_name": "puppetmaster-common",
"binary_version": "3.4.3-1ubuntu1.2"
},
{
"binary_name": "puppetmaster-passenger",
"binary_version": "3.4.3-1ubuntu1.2"
},
{
"binary_name": "vim-puppet",
"binary_version": "3.4.3-1ubuntu1.2"
}
],
"availability": "No subscription required"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "facter",
"purl": "pkg:deb/ubuntu/facter?arch=source&distro=trusty",
"ecosystem": "Ubuntu:14.04:LTS"
},
"versions": [
"1.7.0-1ubuntu1",
"1.7.2-1ubuntu1",
"1.7.3-1ubuntu1",
"1.7.5-1ubuntu1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2014/UBUNTU-CVE-2014-3248.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "facter",
"binary_version": "1.7.5-1ubuntu1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "facter",
"purl": "pkg:deb/ubuntu/facter?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"4.10.0-1build1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2014/UBUNTU-CVE-2014-3248.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "facter",
"binary_version": "4.10.0-1build1"
}
]
}
}
],
"modified": "2026-10-17T12:52:47.552554332Z",
"provider": "osv",
"upstream": [
"CVE-2014-3248"
],
"references": [
"https://ubuntu.com/security/CVE-2014-3248",
"https://ubuntu.com/security/notices/USN-3308-1",
"https://www.cve.org/CVERecord?id=CVE-2014-3248"
]
},
"related_cves": [
{
"value": "CVE-2014-3248",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 353297,
"published_at": "2014-11-16T00:00:00+00:00"
}