glpi subject to Cross-site Scripting (XSS) - Reflected
GLPI is a Free Asset and IT Management Software package. Versions 9.4.0 and above, prior to 10.0.6 are subject to Cross-site Scripting. An attacker can persuade a victim into opening a URL containing a payload exploiting this vulnerability. After exploited, the attacker can make actions as the victim or exfiltrate session cookies. This issue is patched in version 10.0.6.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-22722
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 03:05 UTC · Revision 1
Source evidence
glpi subject to Cross-site Scripting (XSS) - Reflected
core-osv · Original sourcePublished 25 Jan 2023, 05:58 UTC
GLPI is a Free Asset and IT Management Software package. Versions 9.4.0 and above, prior to 10.0.6 are subject to Cross-site Scripting. An attacker can persuade a victim into opening a URL containing a payload exploiting this vulnerability. After exploited, the attacker can make actions as the victim or exfiltrate session cookies. This issue is patched in version 10.0.6.
osv:CVE-2023-22722
Complete source record
{
"id": "5f935ab90ac28400c65a0014d895a25f61ef36112a693fd92bab98ad57664199",
"url": "https://osv.dev/vulnerability/CVE-2023-22722",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "glpi subject to Cross-site Scripting (XSS) - Reflected",
"summary": "GLPI is a Free Asset and IT Management Software package. Versions 9.4.0 and above, prior to 10.0.6 are subject to Cross-site Scripting. An attacker can persuade a victim into opening a URL containing a payload exploiting this vulnerability. After exploited, the attacker can make actions as the victim or exfiltrate session cookies. This issue is patched in version 10.0.6.",
"evidence": "osv:CVE-2023-22722",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-22722",
"aliases": [
"CVE-2023-22722",
"GHSA-352j-wr38-493c"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/glpi-project/glpi",
"type": "GIT",
"events": [
{
"introduced": "1783b781b221fe4212806c910dec3898c079c59f"
},
{
"fixed": "4f7279aeec029817ebe9a209dfeec49d6c9ca11c"
},
{
"introduced": "815997021a5df4feb7077a12f6f52769e9bd3459"
},
{
"fixed": "e2d0f893191952f35c6b1a6013418308e3e1dbc2"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "9.4.0"
},
{
"fixed": "9.5.12"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "10.0.0"
},
{
"fixed": "10.0.6"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"9.5.11",
"10.0.5",
"9.5.10",
"10.0.4",
"9.5.9",
"10.0.3",
"9.5.8",
"10.0.2",
"10.0.1",
"10.0.0",
"9.5.7",
"9.5.6",
"9.5.5",
"9.5.4",
"9.5.3",
"9.5.2",
"9.5.1",
"9.5.0",
"9.5.0-rc2",
"9.5.0-rc1",
"9.4.1.1",
"9.4.1",
"9.4.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-22722.json"
}
}
],
"modified": "2026-10-28T02:30:32.780965937Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/22xxx/CVE-2023-22722.json",
"https://github.com/glpi-project/glpi/security/advisories/GHSA-352j-wr38-493c",
"https://nvd.nist.gov/vuln/detail/CVE-2023-22722"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/22xxx/CVE-2023-22722.json"
}
},
"related_cves": [
{
"value": "CVE-2023-22722",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 499882,
"published_at": "2023-01-25T05:58:01.087+00:00"
}