PSIRT SSL-VPN Reflected XSS
An authenticated remote user may execute code or commands through crafted requests when Agentless SSL-VPN is enabled. The announcement lists fixes for affected FortiOS, FortiPAM and FortiProxy versions.
- Products
- FortiOS, FortiPAM, FortiProxy
- Affected versions
- 1.0 all versions, 1.1 all versions, 1.2 all versions, 1.3 all versions, 1.4 all versions, 1.5 all versions, 1.6 all versions, 1.7 all versions, 1.8.0, 7.2 all versions, 7.2.0 through 7.2.9, 7.4 all versions, 7.4.0 through 7.4.3, 7.6.0 through 7.6.6
- Fixed versions
- 1.8.1 or above, 7.2.10 or above, 7.4.4 or above, 7.6.7 or above
- CVEs
- CVE-2026-23573
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 20:37 UTC · Revision 1
Source evidence
PSIRT SSL-VPN Reflected XSS
official-fortinet-psirt · Original sourcePublished 14 Jul 2026, 07:00 UTC
An authenticated remote user may execute code or commands through crafted requests when Agentless SSL-VPN is enabled. The announcement lists fixes for affected FortiOS, FortiPAM and FortiProxy versions.
An Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability [CWE-79] in FortiOS, FortiProxy, FortiPAM and FortiSwitch-Manager Agentless SSL-VPN may allow an authenticated remote user to execute code or commands via crafted requests.
FortiOS
Fixed versions: 7.6.7 or above
Prerequisites: Agentless SSL-VPN; If this feature is not enabled, there is no impact.
FortiPAM
Fixed versions: 1.8.1 or above
Prerequisites: Agentless SSL-VPN; If this feature is not enabled, there is no impact.
FortiProxy
Fixed versions: 7.4.4 or above, 7.2.10 or above
Prerequisites: Agentless SSL-VPN; If this feature is not enabled, there is no impact.
Complete source record
{
"id": "9639ab8474dc61e9c52442c5a4106b9abccb3d85fe076d1c7b659ee6be35ed0f",
"url": "https://fortiguard.fortinet.com/psirt/FG-IR-26-150",
"method": "llm",
"payload": {
"kind": "patch",
"title": "PSIRT SSL-VPN Reflected XSS",
"summary": "An authenticated remote user may execute code or commands through crafted requests when Agentless SSL-VPN is enabled. The announcement lists fixes for affected FortiOS, FortiPAM and FortiProxy versions.",
"evidence": "An Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability [CWE-79] in FortiOS, FortiProxy, FortiPAM and FortiSwitch-Manager Agentless SSL-VPN may allow an authenticated remote user to execute code or commands via crafted requests.",
"products": [
{
"name": {
"value": "FortiOS",
"evidence": "FortiOS 7.6"
},
"prerequisites": [
{
"value": "Agentless SSL-VPN",
"evidence": "This issue affects only the Agentless SSL-VPN."
},
{
"value": "If this feature is not enabled, there is no impact.",
"evidence": "If this feature is not enabled, there is no impact."
}
],
"fixed_versions": [
{
"value": "7.6.7 or above",
"evidence": "Upgrade to 7.6.7 or above"
}
],
"affected_versions": [
{
"value": "7.6.0 through 7.6.6",
"evidence": "7.6.0 through 7.6.6"
},
{
"value": "7.4 all versions",
"evidence": "7.4 all versions"
},
{
"value": "7.2 all versions",
"evidence": "7.2 all versions"
}
]
},
{
"name": {
"value": "FortiPAM",
"evidence": "FortiPAM 1.8"
},
"prerequisites": [
{
"value": "Agentless SSL-VPN",
"evidence": "This issue affects only the Agentless SSL-VPN."
},
{
"value": "If this feature is not enabled, there is no impact.",
"evidence": "If this feature is not enabled, there is no impact."
}
],
"fixed_versions": [
{
"value": "1.8.1 or above",
"evidence": "Upgrade to 1.8.1 or above"
}
],
"affected_versions": [
{
"value": "1.8.0",
"evidence": "1.8.0 Upgrade to 1.8.1 or above"
},
{
"value": "1.7 all versions",
"evidence": "1.7 all versions"
},
{
"value": "1.6 all versions",
"evidence": "1.6 all versions"
},
{
"value": "1.5 all versions",
"evidence": "1.5 all versions"
},
{
"value": "1.4 all versions",
"evidence": "1.4 all versions"
},
{
"value": "1.3 all versions",
"evidence": "1.3 all versions"
},
{
"value": "1.2 all versions",
"evidence": "1.2 all versions"
},
{
"value": "1.1 all versions",
"evidence": "1.1 all versions"
},
{
"value": "1.0 all versions",
"evidence": "1.0 all versions"
}
]
},
{
"name": {
"value": "FortiProxy",
"evidence": "FortiProxy 7.4"
},
"prerequisites": [
{
"value": "Agentless SSL-VPN",
"evidence": "This issue affects only the Agentless SSL-VPN."
},
{
"value": "If this feature is not enabled, there is no impact.",
"evidence": "If this feature is not enabled, there is no impact."
}
],
"fixed_versions": [
{
"value": "7.4.4 or above",
"evidence": "Upgrade to 7.4.4 or above"
},
{
"value": "7.2.10 or above",
"evidence": "Upgrade to 7.2.10 or above"
}
],
"affected_versions": [
{
"value": "7.4.0 through 7.4.3",
"evidence": "7.4.0 through 7.4.3"
},
{
"value": "7.2.0 through 7.2.9",
"evidence": "7.2.0 through 7.2.9"
}
]
}
],
"severity": "medium",
"fixed_cves": [],
"related_cves": [
{
"value": "CVE-2026-23573",
"evidence": "CVE ID CVE-2026-23573"
}
],
"security_relevant": true,
"severity_evidence": "Severity Medium"
},
"source_id": "official-fortinet-psirt",
"document_id": 23588,
"published_at": "2026-07-14T07:00:00+00:00"
}