Skip to content
Heist/ feed
Back to feed
UnratedFix available

CVE-2023-50386: Apache Solr: Backup/Restore APIs allow for deployment of executables in malicious ConfigSets

Type: patchSources: Apache Solr security

Apache Solr’s ConfigSets and backup behavior could allow uploaded Java files to be used by a ClassLoader. The announcement recommends upgrading to a fixed version.

Products
Apache Solr
Affected versions
6.0.0 through 8.11.2, 9.0.0 before 9.4.1
Fixed versions
8.11.3, 9.4.1
CVEs
CVE-2023-50386
Confirmed fixed CVEs
CVE-2023-50386
Updated in this feed
30 Oct 2026, 21:30 UTC · Revision 1

Source evidence

CVE-2023-50386: Apache Solr: Backup/Restore APIs allow for deployment of executables in malicious ConfigSets

official-apache-solr-security · Original source

Published 8 Feb 2024, 00:00 UTC

Apache Solr’s ConfigSets and backup behavior could allow uploaded Java files to be used by a ClassLoader. The announcement recommends upgrading to a fixed version.

Users are recommended to upgrade to version 8.11.3 or 9.4.1, which fix the issue.

Apache Solr

Fixed versions: 8.11.3, 9.4.1

Prerequisites: Authorization enabled

Complete source record
{
  "id": "748c1061b914ca09134ca69db57720607fe38605261e3dd1a60846f0a91d1ac0",
  "url": "https://solr.apache.org/cve-2023-50386-apache-solr-backuprestore-apis-allow-for-deployment-of-executables-in-malicious-configsets.html",
  "method": "llm",
  "payload": {
    "kind": "patch",
    "title": "CVE-2023-50386: Apache Solr: Backup/Restore APIs allow for deployment of executables in malicious ConfigSets",
    "summary": "Apache Solr’s ConfigSets and backup behavior could allow uploaded Java files to be used by a ClassLoader. The announcement recommends upgrading to a fixed version.",
    "evidence": "Users are recommended to upgrade to version 8.11.3 or 9.4.1, which fix the issue.",
    "products": [
      {
        "name": {
          "value": "Apache Solr",
          "evidence": "Apache Solr 6.0.0 through 8.11.2"
        },
        "prerequisites": [
          {
            "value": "Authorization enabled",
            "evidence": "When Solr is run in a secure way (Authorization enabled), as is strongly suggested"
          }
        ],
        "fixed_versions": [
          {
            "value": "8.11.3",
            "evidence": "upgrade to version 8.11.3 or 9.4.1, which fix the issue"
          },
          {
            "value": "9.4.1",
            "evidence": "upgrade to version 8.11.3 or 9.4.1, which fix the issue"
          }
        ],
        "affected_versions": [
          {
            "value": "6.0.0 through 8.11.2",
            "evidence": "Apache Solr 6.0.0 through 8.11.2"
          },
          {
            "value": "9.0.0 before 9.4.1",
            "evidence": "Apache Solr 9.0.0 before 9.4.1"
          }
        ]
      }
    ],
    "severity": "unknown",
    "fixed_cves": [
      {
        "cve": "CVE-2023-50386",
        "product": "Apache Solr",
        "evidence": "Apache Solr - solr/security\nCVE-2023-50386: Apache Solr: Backup/Restore APIs allow for deployment of executables in malicious ConfigSets\n\nSeverity: Moderate Versions Affected: Apache Solr 6.0.0 through 8.11.2 Apache Solr 9.0.0 before 9.4.1 Description: Improper Control of Dynamically-Managed Code Resources, Unrestricted Upload of File with Dangerous Type, Inclusion of Functionality from Untrusted Control Sphere vulnerability in Apache Solr.This issue affects Apache Solr: from 6.0.0 through 8.11.2, from 9.0.0 before 9.4.1. In the affected versions, Solr ConfigSets accepted Java jar and class files to be uploaded through the ConfigSets API. When backing up Solr Collections, these configSet files would be saved to disk when using the LocalFileSystemRepository (the default for backups). If the backup was saved to a directory that Solr uses in its ClassPath/ClassLoaders, then the jar and class files would be available to use with any ConfigSet, trusted or untrusted. When Solr is run in a secure way (Authorization enabled), as is strongly suggested, this vulnerability is limited to extending the Backup permissions with the ability to add libraries. Mitigation: Users are recommended to upgrade to version 8.11.3 or 9.4.1, which fix the issue."
      }
    ],
    "related_cves": [
      {
        "value": "CVE-2023-50386",
        "evidence": "CVE - CVE-2023-50386"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "official-apache-solr-security",
  "document_id": 22981,
  "published_at": "2024-02-08T00:00:00+00:00"
}