Skip to content
Heist/ feed
Back to feed
HighFix available

GNU Emacs: Arbitrary code execution — GLSA 202608-18

Type: patchSources: Gentoo GLSA

A vulnerability in GNU Emacs could allow arbitrary code execution when a user opens a file with malicious content. Upgrade to the fixed package version for the applicable Emacs branch.

Products
app-editors/emacs
Affected versions
< 28.2-r21, < 29.4-r9, < 30.2-r5
Fixed versions
>= 28.2-r21, >= 29.4-r9, >= 30.2-r5
CVEs
Not specified
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 23:09 UTC · Revision 1

Source evidence

GNU Emacs: Arbitrary code execution — GLSA 202608-18

official-gentoo-glsa · Original source

Published 20 Aug 2026, 00:00 UTC

A vulnerability in GNU Emacs could allow arbitrary code execution when a user opens a file with malicious content. Upgrade to the fixed package version for the applicable Emacs branch.

A vulnerability has been discovered in GNU Emacs which could lead to arbitrary code execution.

app-editors/emacs

Fixed versions: >= 28.2-r21, >= 29.4-r9, >= 30.2-r5

Prerequisites: by tricking a user into opening a file with malicious content

Complete source record
{
  "id": "eed1a05d92ceedbdb9f08ac748e8e85699e65db4d135ac07c4ae8180b5927669",
  "url": "https://security.gentoo.org/glsa/202608-18",
  "method": "llm",
  "payload": {
    "kind": "patch",
    "title": "GNU Emacs: Arbitrary code execution — GLSA 202608-18",
    "summary": "A vulnerability in GNU Emacs could allow arbitrary code execution when a user opens a file with malicious content. Upgrade to the fixed package version for the applicable Emacs branch.",
    "evidence": "A vulnerability has been discovered in GNU Emacs which could lead to arbitrary code execution.",
    "products": [
      {
        "name": {
          "value": "app-editors/emacs",
          "evidence": "Affected packages Package app-editors/emacs on all architectures"
        },
        "prerequisites": [
          {
            "value": "by tricking a user into opening a file with malicious content",
            "evidence": "An attacker could achieve arbitrary code execution by tricking a user into opening a file with malicious content."
          }
        ],
        "fixed_versions": [
          {
            "value": ">= 28.2-r21",
            "evidence": "Unaffected versions >= 28.2-r21 >= 29.4-r9 >= 30.2-r5 < 28"
          },
          {
            "value": ">= 29.4-r9",
            "evidence": "Unaffected versions >= 28.2-r21 >= 29.4-r9 >= 30.2-r5 < 28"
          },
          {
            "value": ">= 30.2-r5",
            "evidence": "Unaffected versions >= 28.2-r21 >= 29.4-r9 >= 30.2-r5 < 28"
          }
        ],
        "affected_versions": [
          {
            "value": "< 28.2-r21",
            "evidence": "Affected versions < 28.2-r21 < 29.4-r9 < 30.2-r5"
          },
          {
            "value": "< 29.4-r9",
            "evidence": "Affected versions < 28.2-r21 < 29.4-r9 < 30.2-r5"
          },
          {
            "value": "< 30.2-r5",
            "evidence": "Affected versions < 28.2-r21 < 29.4-r9 < 30.2-r5"
          }
        ]
      }
    ],
    "severity": "high",
    "fixed_cves": [],
    "related_cves": [],
    "security_relevant": true,
    "severity_evidence": "Severity high"
  },
  "source_id": "official-gentoo-glsa",
  "document_id": 23661,
  "published_at": "2026-08-20T00:00:00+00:00"
}