opennds — security advisory
An issue was discovered in the captive portal in OpenNDS before version 10.1.3. get_query in http_microhttpd.c does not validate the length of the query string of GET requests. This leads to a stack-based buffer overflow in versions 9.x and earlier, and to a heap-based buffer overflow in versions 10.x and later. Attackers may exploit the issue to crash OpenNDS (Denial-of-Service condition) or to inject and execute arbitrary bytecode (Remote Code Execution). Affected OpenNDS before version 10.1.3 fixed in OpenWrt master and OpenWrt 23.05 on 23. November by updating OpenNDS to version 10.2.0.
- Products
- opennds
- Affected versions
- 10.2.0+dfsg-1, 10.3.0+dfsg-0.1, 10.3.1+dfsg-1, 9.10.0-1
- Fixed versions
- 10.2.0+dfsg-1
- CVEs
- CVE-2023-41101
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 15:57 UTC · Revision 1
Source evidence
An issue was discovered in the captive portal in OpenNDS before version 10.1.3. get_query in http_microhttpd.c does not validate the length of the query string of GET requests. This leads to a stack-based buffer overflow in versions 9.x and earlier, and to a heap-based buffer overflow in versions 10.x and later. Attackers may exploit the issue to crash OpenNDS (Denial-of-Service condition) or to inject and execute arbitrary bytecode (Remote Code Execution). Affected OpenNDS before version 10.1.3 fixed in OpenWrt master and OpenWrt 23.05 on 23. November by updating OpenNDS to version 10.2.0.
osv:DEBIAN-CVE-2023-41101
opennds
Fixed versions: Not specified
opennds
Fixed versions: 10.2.0+dfsg-1
Complete source record
{
"id": "5e0171fe425429554bda2cdf58fecb3a210104f4e198e0388447b868c11eb453",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-41101",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-41101",
"summary": "An issue was discovered in the captive portal in OpenNDS before version 10.1.3. get_query in http_microhttpd.c does not validate the length of the query string of GET requests. This leads to a stack-based buffer overflow in versions 9.x and earlier, and to a heap-based buffer overflow in versions 10.x and later. Attackers may exploit the issue to crash OpenNDS (Denial-of-Service condition) or to inject and execute arbitrary bytecode (Remote Code Execution). Affected OpenNDS before version 10.1.3 fixed in OpenWrt master and OpenWrt 23.05 on 23. November by updating OpenNDS to version 10.2.0.",
"evidence": "osv:DEBIAN-CVE-2023-41101",
"products": [
{
"name": {
"value": "opennds",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "10.2.0+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "10.3.0+dfsg-0.1",
"evidence": "/affected/0/versions"
},
{
"value": "10.3.1+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "9.10.0-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "opennds",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "10.2.0+dfsg-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2023-41101",
"aliases": [
"DEBIAN-CVE-2023-41101"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "opennds",
"purl": "pkg:deb/debian/opennds?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"10.2.0+dfsg-1",
"10.3.0+dfsg-0.1",
"10.3.1+dfsg-1",
"9.10.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-41101.json"
},
"ecosystem_specific": {
"urgency": "end-of-life"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "10.2.0+dfsg-1"
}
]
}
],
"package": {
"name": "opennds",
"purl": "pkg:deb/debian/opennds?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-41101.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:02:32.409778106Z",
"provider": "osv",
"upstream": [
"CVE-2023-41101"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-41101"
]
},
"related_cves": [
{
"value": "CVE-2023-41101",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 456205,
"published_at": "2023-11-17T06:15:34.137+00:00"
}