bouncycastle — security advisory
Bouncy Castle for Java before 1.73 contains a potential Denial of Service (DoS) issue within the Bouncy Castle org.bouncycastle.openssl.PEMParser class. This class parses OpenSSL PEM encoded streams containing X.509 certificates, PKCS8 encoded keys, and PKCS7 objects. Parsing a file that has crafted ASN.1 data through the PEMParser causes an OutOfMemoryError, which can enable a denial of service attack. (For users of the FIPS Java API: BC-FJA 1.0.2.3 and earlier are affected; BC-FJA 1.0.2.4 is fixed.)
- Products
- bouncycastle
- Affected versions
- 1.72-2, 1.77-1, 1.80-1, 1.80-2, 1.80-3, 1.86-1
- Fixed versions
- 1.77-1
- CVEs
- CVE-2023-33202
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 16:05 UTC · Revision 1
Source evidence
Bouncy Castle for Java before 1.73 contains a potential Denial of Service (DoS) issue within the Bouncy Castle org.bouncycastle.openssl.PEMParser class. This class parses OpenSSL PEM encoded streams containing X.509 certificates, PKCS8 encoded keys, and PKCS7 objects. Parsing a file that has crafted ASN.1 data through the PEMParser causes an OutOfMemoryError, which can enable a denial of service attack. (For users of the FIPS Java API: BC-FJA 1.0.2.3 and earlier are affected; BC-FJA 1.0.2.4 is fixed.)
osv:DEBIAN-CVE-2023-33202
bouncycastle
Fixed versions: Not specified
bouncycastle
Fixed versions: 1.77-1
bouncycastle
Fixed versions: 1.77-1
Complete source record
{
"id": "f88cbe1fa5bfecd8e80b0c1de26c9a72afcb6b35aef91b8d36459ba5bbd54acd",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-33202",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-33202",
"summary": "Bouncy Castle for Java before 1.73 contains a potential Denial of Service (DoS) issue within the Bouncy Castle org.bouncycastle.openssl.PEMParser class. This class parses OpenSSL PEM encoded streams containing X.509 certificates, PKCS8 encoded keys, and PKCS7 objects. Parsing a file that has crafted ASN.1 data through the PEMParser causes an OutOfMemoryError, which can enable a denial of service attack. (For users of the FIPS Java API: BC-FJA 1.0.2.3 and earlier are affected; BC-FJA 1.0.2.4 is fixed.)",
"evidence": "osv:DEBIAN-CVE-2023-33202",
"products": [
{
"name": {
"value": "bouncycastle",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.72-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.77-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.80-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.80-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.80-3",
"evidence": "/affected/0/versions"
},
{
"value": "1.86-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "bouncycastle",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.77-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "bouncycastle",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.77-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2023-33202",
"aliases": [
"DEBIAN-CVE-2023-33202"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "bouncycastle",
"purl": "pkg:deb/debian/bouncycastle?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.72-2",
"1.77-1",
"1.80-1",
"1.80-2",
"1.80-3",
"1.86-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-33202.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.77-1"
}
]
}
],
"package": {
"name": "bouncycastle",
"purl": "pkg:deb/debian/bouncycastle?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-33202.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.77-1"
}
]
}
],
"package": {
"name": "bouncycastle",
"purl": "pkg:deb/debian/bouncycastle?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-33202.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:02:40.942481676Z",
"provider": "osv",
"upstream": [
"CVE-2023-33202"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-33202"
]
},
"related_cves": [
{
"value": "CVE-2023-33202",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 456583,
"published_at": "2023-11-23T16:15:07.273+00:00"
}