python-oauthlib — security advisory
OAuthLib is an implementation of the OAuth request-signing logic for Python 3.6+. In OAuthLib versions 3.1.1 until 3.2.1, an attacker providing malicious redirect uri can cause denial of service. An attacker can also leverage usage of `uri_validate` functions depending where it is used. OAuthLib applications using OAuth2.0 provider support or use directly `uri_validate` are affected by this issue. Version 3.2.1 contains a patch. There are no known workarounds.
- Products
- python-oauthlib
- Affected versions
- Not specified
- Fixed versions
- 3.2.1-1
- CVEs
- CVE-2022-36087
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:58 UTC · Revision 1
Source evidence
OAuthLib is an implementation of the OAuth request-signing logic for Python 3.6+. In OAuthLib versions 3.1.1 until 3.2.1, an attacker providing malicious redirect uri can cause denial of service. An attacker can also leverage usage of `uri_validate` functions depending where it is used. OAuthLib applications using OAuth2.0 provider support or use directly `uri_validate` are affected by this issue. Version 3.2.1 contains a patch. There are no known workarounds.
osv:DEBIAN-CVE-2022-36087
python-oauthlib
Fixed versions: 3.2.1-1
python-oauthlib
Fixed versions: 3.2.1-1
python-oauthlib
Fixed versions: 3.2.1-1
Complete source record
{
"id": "b8df8207a7c70ffc19f29647e3ba002a919e442c41ba38004a00da202b7cf01e",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-36087",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-36087",
"summary": "OAuthLib is an implementation of the OAuth request-signing logic for Python 3.6+. In OAuthLib versions 3.1.1 until 3.2.1, an attacker providing malicious redirect uri can cause denial of service. An attacker can also leverage usage of `uri_validate` functions depending where it is used. OAuthLib applications using OAuth2.0 provider support or use directly `uri_validate` are affected by this issue. Version 3.2.1 contains a patch. There are no known workarounds.",
"evidence": "osv:DEBIAN-CVE-2022-36087",
"products": [
{
"name": {
"value": "python-oauthlib",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.2.1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "python-oauthlib",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.2.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "python-oauthlib",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.2.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2022-36087",
"aliases": [
"DEBIAN-CVE-2022-36087"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.2.1-1"
}
]
}
],
"package": {
"name": "python-oauthlib",
"purl": "pkg:deb/debian/python-oauthlib?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-36087.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.2.1-1"
}
]
}
],
"package": {
"name": "python-oauthlib",
"purl": "pkg:deb/debian/python-oauthlib?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-36087.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.2.1-1"
}
]
}
],
"package": {
"name": "python-oauthlib",
"purl": "pkg:deb/debian/python-oauthlib?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-36087.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:40.056929223Z",
"provider": "osv",
"upstream": [
"CVE-2022-36087"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-36087"
]
},
"related_cves": [
{
"value": "CVE-2022-36087",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323919,
"published_at": "2022-09-09T21:15:08.477+00:00"
}