ruby — security advisory
URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.
- Products
- ruby
- Affected versions
- Not specified
- Fixed versions
- 3.3.10-r0, 3.4.7-r0
- CVEs
- CVE-2025-61594
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:56 UTC · Revision 1
Source evidence
URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.
osv:ALPINE-CVE-2025-61594
ruby
Fixed versions: 3.3.10-r0
ruby
Fixed versions: 3.3.10-r0
ruby
Fixed versions: 3.4.7-r0
ruby
Fixed versions: 3.4.7-r0
ruby
Fixed versions: 3.4.7-r0
Complete source record
{
"id": "d7cc051b76cf9d1f24df83f4536acbedde987468cbeac53bb53ce68dfb5bdd97",
"url": "https://osv.dev/vulnerability/ALPINE-CVE-2025-61594",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ALPINE-CVE-2025-61594",
"summary": "URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.",
"evidence": "osv:ALPINE-CVE-2025-61594",
"products": [
{
"name": {
"value": "ruby",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.3.10-r0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.3.10-r0",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.4.7-r0",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.4.7-r0",
"evidence": "/affected/3/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby",
"evidence": "/affected/4/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.4.7-r0",
"evidence": "/affected/4/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "ALPINE-CVE-2025-61594",
"aliases": [
"ALPINE-CVE-2025-61594"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.3.10-r0"
}
]
}
],
"package": {
"name": "ruby",
"purl": "pkg:apk/alpine/ruby?arch=source",
"ecosystem": "Alpine:v3.20"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2025-61594.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.3.10-r0"
}
]
}
],
"package": {
"name": "ruby",
"purl": "pkg:apk/alpine/ruby?arch=source",
"ecosystem": "Alpine:v3.21"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2025-61594.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.7-r0"
}
]
}
],
"package": {
"name": "ruby",
"purl": "pkg:apk/alpine/ruby?arch=source",
"ecosystem": "Alpine:v3.22"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2025-61594.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.7-r0"
}
]
}
],
"package": {
"name": "ruby",
"purl": "pkg:apk/alpine/ruby?arch=source",
"ecosystem": "Alpine:v3.23"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2025-61594.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.7-r0"
}
]
}
],
"package": {
"name": "ruby",
"purl": "pkg:apk/alpine/ruby?arch=source",
"ecosystem": "Alpine:v3.24"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2025-61594.json"
},
"ecosystem_specific": {}
}
],
"modified": "2026-10-27T12:30:03.166599236Z",
"provider": "osv",
"upstream": [
"CVE-2025-61594"
],
"references": [
"https://security.alpinelinux.org/vuln/CVE-2025-61594"
]
},
"related_cves": [
{
"value": "CVE-2025-61594",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 461529,
"published_at": "2025-12-30T21:15:43.893+00:00"
}