Payload has a tenant authorization bypass in Multi-Tenant Plugin
## Impact When using the default tenant array field access, an authenticated user could assign themselves to other tenants. **You are affected if:** - You are using `@payloadcms/plugin-multi-tenant` If you configure the tenants arrayFieldAccess.create/update functions, a secured replacement membership field, you are not affected by this specific default behavior. ## Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ## Workarounds Configure tenants arrayFieldAccess.create and tenants arrayFieldAccess.update so only trusted users authorized for all tenants can modify memberships.
- Products
- @payloadcms/plugin-multi-tenant
- Affected versions
- Not specified
- Fixed versions
- 3.90.0, 4.0.0-canary.34
- CVEs
- CVE-2026-105860
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 08:48 UTC · Revision 1
Source evidence
Payload has a tenant authorization bypass in Multi-Tenant Plugin
core-osv · Original sourcePublished 7 Oct 2026, 20:29 UTC
## Impact When using the default tenant array field access, an authenticated user could assign themselves to other tenants. **You are affected if:** - You are using `@payloadcms/plugin-multi-tenant` If you configure the tenants arrayFieldAccess.create/update functions, a secured replacement membership field, you are not affected by this specific default behavior. ## Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ## Workarounds Configure tenants arrayFieldAccess.create and tenants arrayFieldAccess.update so only trusted users authorized for all tenants can modify memberships.
osv:GHSA-p96c-xwx8-3cqj
@payloadcms/plugin-multi-tenant
Fixed versions: 3.90.0
@payloadcms/plugin-multi-tenant
Fixed versions: 4.0.0-canary.34
Complete source record
{
"id": "19df908476326aeee29989a0c9a5c5775985ec9720e13af17f12272ffa7d8f2e",
"url": "https://osv.dev/vulnerability/GHSA-p96c-xwx8-3cqj",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Payload has a tenant authorization bypass in Multi-Tenant Plugin",
"summary": "## Impact When using the default tenant array field access, an authenticated user could assign themselves to other tenants. **You are affected if:** - You are using `@payloadcms/plugin-multi-tenant` If you configure the tenants arrayFieldAccess.create/update functions, a secured replacement membership field, you are not affected by this specific default behavior. ## Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ## Workarounds Configure tenants arrayFieldAccess.create and tenants arrayFieldAccess.update so only trusted users authorized for all tenants can modify memberships.",
"evidence": "osv:GHSA-p96c-xwx8-3cqj",
"products": [
{
"name": {
"value": "@payloadcms/plugin-multi-tenant",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.90.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "@payloadcms/plugin-multi-tenant",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.0.0-canary.34",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "GHSA-p96c-xwx8-3cqj",
"aliases": [
"CVE-2026-105860",
"GHSA-p96c-xwx8-3cqj"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.90.0"
}
]
}
],
"package": {
"name": "@payloadcms/plugin-multi-tenant",
"purl": "pkg:npm/%40payloadcms/plugin-multi-tenant",
"ecosystem": "npm"
},
"database_specific": {
"source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-p96c-xwx8-3cqj/GHSA-p96c-xwx8-3cqj.json"
}
},
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "4.0.0-canary.0"
},
{
"fixed": "4.0.0-canary.34"
}
]
}
],
"package": {
"name": "@payloadcms/plugin-multi-tenant",
"purl": "pkg:npm/%40payloadcms/plugin-multi-tenant",
"ecosystem": "npm"
},
"database_specific": {
"source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-p96c-xwx8-3cqj/GHSA-p96c-xwx8-3cqj.json"
}
}
],
"modified": "2026-10-07T20:45:05.342379505Z",
"provider": "osv",
"references": [
"https://github.com/payloadcms/payload/security/advisories/GHSA-p96c-xwx8-3cqj",
"https://nvd.nist.gov/vuln/detail/CVE-2026-105860",
"https://github.com/payloadcms/payload/commit/19b58692d20d3947f31124bf7a88ac14a5ebf02e",
"https://github.com/payloadcms/payload",
"https://github.com/payloadcms/payload/releases/tag/v3.90.0"
],
"provider_metadata": {
"cwe_ids": [
"CWE-862"
],
"severity": "HIGH",
"github_reviewed": true,
"nvd_published_at": "2026-10-06T17:17:22Z",
"github_reviewed_at": "2026-10-07T20:29:53Z"
}
},
"related_cves": [
{
"value": "CVE-2026-105860",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 97266,
"published_at": "2026-10-07T20:29:53+00:00"
}