Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2017-1000188

nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2017-1000188
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 09:48 UTC · Revision 1

Source evidence

CVE-2017-1000188

core-osv · Original source

Published 17 Nov 2017, 03:29 UTC

nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection

osv:CVE-2017-1000188
Complete source record
{
  "id": "4b1fcd1e2830f5b42ce4dccd5e6d1a7b2ae74fdd51e9836e01853987d12088bb",
  "url": "https://osv.dev/vulnerability/CVE-2017-1000188",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2017-1000188",
    "summary": "nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection",
    "evidence": "osv:CVE-2017-1000188",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2017-1000188",
      "aliases": [
        "CVE-2017-1000188",
        "GHSA-hwcf-pp87-7x6p"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/mde/ejs",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "a63b9731c49c62358bb3f220839a64cd66652a40"
                },
                {
                  "fixed": "49264e0037e313a0a3e033450b5c184112516d8f"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:ejs:ejs:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.5.5"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "49264e0037e313a0a3e033450b5c184112516d8f"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.5.3",
            "v2.5.2",
            "v2.5.1",
            "v2.4.2",
            "v2.4.1",
            "v2.3.4",
            "v2.3.3",
            "v2.3.2",
            "v2.3.1",
            "v2.2.4",
            "v2.2.3",
            "v2.2.2",
            "v2.2.1",
            "v2.1.4",
            "v2.1.3",
            "v2.1.2",
            "v2.1.1",
            "v2.0.2",
            "v2.0.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-1000188.json"
          }
        }
      ],
      "modified": "2026-10-20T10:48:00.327935048Z",
      "provider": "osv",
      "references": [
        "https://github.com/mde/ejs/commit/49264e0037e313a0a3e033450b5c184112516d8f"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2017-1000188",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 379926,
  "published_at": "2017-11-17T03:29:00.267+00:00"
}