CriticalFix available
apache2 — security advisory
ap_escape_quotes() may write beyond the end of a buffer when given malicious input. No included modules pass untrusted data to these functions, but third-party / external modules may. This issue affects Apache HTTP Server 2.4.48 and earlier.
- Products
- apache2
- Affected versions
- Not specified
- Fixed versions
- 2.4.49-1
- CVEs
- CVE-2021-39275
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:39 UTC · Revision 1
Source evidence
ap_escape_quotes() may write beyond the end of a buffer when given malicious input. No included modules pass untrusted data to these functions, but third-party / external modules may. This issue affects Apache HTTP Server 2.4.48 and earlier.
osv:DEBIAN-CVE-2021-39275
apache2
Fixed versions: 2.4.49-1
apache2
Fixed versions: 2.4.49-1
apache2
Fixed versions: 2.4.49-1
Complete source record
{
"id": "857e24f33196becfd5b96431ac95eed1755e3fd25245b8c6f95e5720db78e3c0",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-39275",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-39275",
"summary": "ap_escape_quotes() may write beyond the end of a buffer when given malicious input. No included modules pass untrusted data to these functions, but third-party / external modules may. This issue affects Apache HTTP Server 2.4.48 and earlier.",
"evidence": "osv:DEBIAN-CVE-2021-39275",
"products": [
{
"name": {
"value": "apache2",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.49-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "apache2",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.49-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "apache2",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.49-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2021-39275",
"aliases": [
"DEBIAN-CVE-2021-39275"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.49-1"
}
]
}
],
"package": {
"name": "apache2",
"purl": "pkg:deb/debian/apache2?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-39275.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.49-1"
}
]
}
],
"package": {
"name": "apache2",
"purl": "pkg:deb/debian/apache2?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-39275.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.49-1"
}
]
}
],
"package": {
"name": "apache2",
"purl": "pkg:deb/debian/apache2?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-39275.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:32.113835520Z",
"provider": "osv",
"upstream": [
"CVE-2021-39275"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-39275"
]
},
"related_cves": [
{
"value": "CVE-2021-39275",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 421826,
"published_at": "2021-09-16T15:15:07.58+00:00"
}