CriticalFix available
py3-pillow — security advisory
PIL.ImageMath.eval in Pillow before 9.0.0 allows evaluation of arbitrary expressions, such as ones that use the Python exec method. A lambda expression could also be used.
- Products
- py3-pillow
- Affected versions
- Not specified
- Fixed versions
- 8.4.0-r3
- CVEs
- CVE-2022-22817
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:10 UTC · Revision 1
Source evidence
PIL.ImageMath.eval in Pillow before 9.0.0 allows evaluation of arbitrary expressions, such as ones that use the Python exec method. A lambda expression could also be used.
osv:ALPINE-CVE-2022-22817
py3-pillow
Fixed versions: 8.4.0-r3
Complete source record
{
"id": "ec4a3c78be617ed301a4a787bc4abcfda4aacba639dc90a0df8de22faca084b0",
"url": "https://osv.dev/vulnerability/ALPINE-CVE-2022-22817",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ALPINE-CVE-2022-22817",
"summary": "PIL.ImageMath.eval in Pillow before 9.0.0 allows evaluation of arbitrary expressions, such as ones that use the Python exec method. A lambda expression could also be used.",
"evidence": "osv:ALPINE-CVE-2022-22817",
"products": [
{
"name": {
"value": "py3-pillow",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "8.4.0-r3",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "ALPINE-CVE-2022-22817",
"aliases": [
"ALPINE-CVE-2022-22817"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "8.4.0-r3"
}
]
}
],
"package": {
"name": "py3-pillow",
"purl": "pkg:apk/alpine/py3-pillow?arch=source",
"ecosystem": "Alpine:v3.15"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2022-22817.json"
},
"ecosystem_specific": {}
}
],
"modified": "2026-10-15T07:17:54.162170198Z",
"provider": "osv",
"upstream": [
"CVE-2022-22817"
],
"references": [
"https://security.alpinelinux.org/vuln/CVE-2022-22817"
]
},
"related_cves": [
{
"value": "CVE-2022-22817",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 321684,
"published_at": "2022-01-10T14:12:55.16+00:00"
}