UnratedFix available
mediawiki — security advisory
Cross-site scripting (XSS) vulnerability in Special:PasswordReset in MediaWiki before 1.19.16, 1.21.x before 1.21.10, and 1.22.x before 1.22.7, when wgRawHtml is enabled, allows remote attackers to inject arbitrary web script or HTML via an invalid username.
- Products
- mediawiki
- Affected versions
- Not specified
- Fixed versions
- 1:1.19.16+dfsg-1
- CVEs
- CVE-2014-3966
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:44 UTC · Revision 1
Source evidence
Cross-site scripting (XSS) vulnerability in Special:PasswordReset in MediaWiki before 1.19.16, 1.21.x before 1.21.10, and 1.22.x before 1.22.7, when wgRawHtml is enabled, allows remote attackers to inject arbitrary web script or HTML via an invalid username.
osv:DEBIAN-CVE-2014-3966
mediawiki
Fixed versions: 1:1.19.16+dfsg-1
mediawiki
Fixed versions: 1:1.19.16+dfsg-1
mediawiki
Fixed versions: 1:1.19.16+dfsg-1
Complete source record
{
"id": "b34da9510616cedff6587533a9232c94651a6cbcb0560a8f77eac55ca24a350c",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-3966",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-3966",
"summary": "Cross-site scripting (XSS) vulnerability in Special:PasswordReset in MediaWiki before 1.19.16, 1.21.x before 1.21.10, and 1.22.x before 1.22.7, when wgRawHtml is enabled, allows remote attackers to inject arbitrary web script or HTML via an invalid username.",
"evidence": "osv:DEBIAN-CVE-2014-3966",
"products": [
{
"name": {
"value": "mediawiki",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:1.19.16+dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "mediawiki",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:1.19.16+dfsg-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "mediawiki",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:1.19.16+dfsg-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2014-3966",
"aliases": [
"DEBIAN-CVE-2014-3966"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:1.19.16+dfsg-1"
}
]
}
],
"package": {
"name": "mediawiki",
"purl": "pkg:deb/debian/mediawiki?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-3966.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:1.19.16+dfsg-1"
}
]
}
],
"package": {
"name": "mediawiki",
"purl": "pkg:deb/debian/mediawiki?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-3966.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:1.19.16+dfsg-1"
}
]
}
],
"package": {
"name": "mediawiki",
"purl": "pkg:deb/debian/mediawiki?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-3966.json"
},
"ecosystem_specific": {
"urgency": "low"
}
}
],
"modified": "2026-10-23T15:47:34.714084627Z",
"provider": "osv",
"upstream": [
"CVE-2014-3966"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-3966"
]
},
"related_cves": [
{
"value": "CVE-2014-3966",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 414277,
"published_at": "2014-06-06T14:55:05.227+00:00"
}