Medium
Security advisory
GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI from version 9.5.0 and before version 9.5.4, there is a cross-site scripting injection vulnerability when using ajax/kanban.php. This is fixed in version 9.5.4.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-21258
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:31 UTC · Revision 1
Source evidence
GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI from version 9.5.0 and before version 9.5.4, there is a cross-site scripting injection vulnerability when using ajax/kanban.php. This is fixed in version 9.5.4.
osv:CVE-2021-21258
Complete source record
{
"id": "70b9c76d32d0f38ce1d6ad78c00502235c3d797fa3650f6ee35b418c6cbc54ff",
"url": "https://osv.dev/vulnerability/CVE-2021-21258",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-21258",
"summary": "GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI from version 9.5.0 and before version 9.5.4, there is a cross-site scripting injection vulnerability when using ajax/kanban.php. This is fixed in version 9.5.4.",
"evidence": "osv:CVE-2021-21258",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-21258",
"aliases": [
"CVE-2021-21258",
"GHSA-j4xj-4qmc-mmmx"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/glpi-project/glpi",
"type": "GIT",
"events": [
{
"introduced": "9fa6de558a9987561b80afd57a796a3fa19deee6"
},
{
"fixed": "59a0a0b6101fcd54b00bfc6a61d4e707513c08c9"
},
{
"fixed": "e7802fc051696de1f76108ea8dc3bd4e2c880f15"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "9.5.0"
},
{
"fixed": "9.5.4"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "e7802fc051696de1f76108ea8dc3bd4e2c880f15"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"9.5.3",
"9.5.2",
"9.5.1",
"9.5.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21258.json"
}
}
],
"modified": "2026-10-20T10:54:27.864432465Z",
"provider": "osv",
"references": [
"https://github.com/glpi-project/glpi/security/advisories/GHSA-j4xj-4qmc-mmmx",
"https://github.com/glpi-project/glpi/commit/e7802fc051696de1f76108ea8dc3bd4e2c880f15"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-21258",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385388,
"published_at": "2021-03-02T20:15:14.707+00:00"
}