Skip to content
Heist/ feed
Back to feed
CriticalFix available

Payload: SQL Injection in SQLite and Postgres

Type: advisorySources: OSV

### Impact A user can submit a request that exploits a SQL Injection vulnerability in Payload. You are affected if: - You use an affected Payload version. - Untrusted users can query readable collections using dynamic filters or joins. You are not affected if you use MongoDB (`@payloadcms/mongodb`). ### Patches Users should upgrade Payload packages to `>= 3.88.0` or `>= 4.0.0-canary.27`. ### Workarounds Upgrading to a patched version is recommended. Until you can upgrade, restrict untrusted users from supplying dynamic query filters or join parameters and limit read access to affected collections.

Products
payload
Affected versions
Not specified
Fixed versions
3.88.0, 4.0.0-canary.27
CVEs
CVE-2026-105845
Confirmed fixed CVEs
Not specified
Updated in this feed
27 Oct 2026, 12:11 UTC · Revision 1

Source evidence

Payload: SQL Injection in SQLite and Postgres

core-osv · Original source

Published 6 Oct 2026, 16:09 UTC

### Impact A user can submit a request that exploits a SQL Injection vulnerability in Payload. You are affected if: - You use an affected Payload version. - Untrusted users can query readable collections using dynamic filters or joins. You are not affected if you use MongoDB (`@payloadcms/mongodb`). ### Patches Users should upgrade Payload packages to `>= 3.88.0` or `>= 4.0.0-canary.27`. ### Workarounds Upgrading to a patched version is recommended. Until you can upgrade, restrict untrusted users from supplying dynamic query filters or join parameters and limit read access to affected collections.

osv:GHSA-v49j-62m6-pgrr

payload

Fixed versions: 3.88.0

payload

Fixed versions: 4.0.0-canary.27

Complete source record
{
  "id": "5f4ac7e542327def527bd5dc5c59288bd91268b8b80704f3165b3df5dc35d696",
  "url": "https://osv.dev/vulnerability/GHSA-v49j-62m6-pgrr",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Payload: SQL Injection in SQLite and Postgres",
    "summary": "### Impact A user can submit a request that exploits a SQL Injection vulnerability in Payload. You are affected if: - You use an affected Payload version. - Untrusted users can query readable collections using dynamic filters or joins. You are not affected if you use MongoDB (`@payloadcms/mongodb`). ### Patches Users should upgrade Payload packages to `>= 3.88.0` or `>= 4.0.0-canary.27`. ### Workarounds Upgrading to a patched version is recommended. Until you can upgrade, restrict untrusted users from supplying dynamic query filters or join parameters and limit read access to affected collections.",
    "evidence": "osv:GHSA-v49j-62m6-pgrr",
    "products": [
      {
        "name": {
          "value": "payload",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.88.0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "payload",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4.0.0-canary.27",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "GHSA-v49j-62m6-pgrr",
      "aliases": [
        "CVE-2026-105845",
        "GHSA-v49j-62m6-pgrr"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "3.0.0"
                },
                {
                  "fixed": "3.88.0"
                }
              ]
            }
          ],
          "package": {
            "name": "payload",
            "purl": "pkg:npm/payload",
            "ecosystem": "npm"
          },
          "database_specific": {
            "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-v49j-62m6-pgrr/GHSA-v49j-62m6-pgrr.json"
          }
        },
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "4.0.0-canary.0"
                },
                {
                  "fixed": "4.0.0-canary.27"
                }
              ]
            }
          ],
          "package": {
            "name": "payload",
            "purl": "pkg:npm/payload",
            "ecosystem": "npm"
          },
          "database_specific": {
            "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-v49j-62m6-pgrr/GHSA-v49j-62m6-pgrr.json"
          }
        }
      ],
      "modified": "2026-10-06T16:15:04.829817763Z",
      "provider": "osv",
      "references": [
        "https://github.com/payloadcms/payload/security/advisories/GHSA-v49j-62m6-pgrr",
        "https://github.com/payloadcms/payload/commit/a742140ab4fca3160f7f83e9e7d996552ffc3b5a",
        "https://github.com/payloadcms/payload",
        "https://github.com/payloadcms/payload/releases/tag/v3.88.0"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-89"
        ],
        "severity": "CRITICAL",
        "github_reviewed": true,
        "nvd_published_at": null,
        "github_reviewed_at": "2026-10-06T16:09:17Z"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-105845",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 89307,
  "published_at": "2026-10-06T16:09:17+00:00"
}